Expression Error

Just fired up onlyoffice Version server in a vm. Logged in and tried to open My Documents and was confronted with this error:
Screenshot from 2023-12-14 10-33-31
This had been running ok 6 months ago.

Any idea how to resolve this error ?

hey @neogrid :handshake:

There are a few questions…

  1. Have you not been using the ONLYOFFICE Workspace server for half a year? :upside_down_face:
  2. What system did you install ONLYOFFICE Workspace Community on?
  3. Docker/exe/deb/rpm?
    4. How did you last stop the server?

It seems that there is a problem with the database…

Hi @Nikolas thanks for trying to help!

In response to your queries:

  1. Yeah I set it up a while ago then put it on the back burner.
  2. The host OS is debian 11
  3. It’s running in a proxmox virtual machine with debian as a host OS, I used the script to install OnlyOffice all components on the single server.
  4. Good question, it’s likely I “Stopped” the VM within proxmox.

I did try powering down and rebooting the vm, no change.
Tried restoring an older image, but had the same fault.

We have one script, but it installs either Docker or deb/rpm depending on the answer.

To start the installation process, run the following command:


Once you enter the above command, you will be prompted to select the way you want to install ONLYOFFICE Workspace.
Type N and press Enter to install ONLYOFFICE Workspace using RPM/DEB packages.

If there are no important files on that server, you can simply reinstall ONLYOFFICE Workspace.

Otherwise, most likely, you’ll have to delve into the database.

Most likely, there were issues with MySQL during the server stopped.

Ok thanks, I’m not fully confident to move it into full use as the risk of losing data in the future is to high. Was hoping this error was seen / common. Yeah can reinstall but that doesn’t sound like the best solution.

If resolving this issue is crucial for you, you may consider reaching out to the sales department. The support team should be able to assist you with database-related problems.

However, I would like to note that, in my two years of experience, I haven’t encountered a similar issue when the server was correctly stopped. :thinking:

Ok thanks for the suggestion. I need to do more investigation on back up and data recovery. Though running in a vm will be my approach, sometimes I need to kill the vm for whatever reason, it’s the first time I’ve seen a db corrupted like this.

I can only speculate about what could have caused the database to be corrupted, since there is no additional information available. :thinking:

However, I can say one thing with certainty—the issue lies within the database.