Error with PDF conversion


I’ve tried to make a document to PDF conversion using this script:

builder.SaveFile("pdf", "Sample.pdf");

But this error is thrown and I’m not sure which info is missing:

TypeError: Cannot read property 'length' of undefined
    at Object.a.AscCommon.yK.decode.a.AscCommon.yK.decode (<anonymous>:12281:172)
    at e (<anonymous>:12196:526)
    at n.On (<anonymous>:12216:377)
    at Object.On (<anonymous>:12221:177)
    at g.e.T4c (<anonymous>:10608:404)
    at g.T4c (<anonymous>:10946:79)
    at <anonymous>:10553:418
    at ra (<anonymous>:10027:381)
    at Object.a.AscCommon.WFg (<anonymous>:10195:405)
    at g.e.qla (<anonymous>:10553:381)

# Fatal error in v8::ToLocalChecked
# Empty MaybeLocal.

Hello @Monkiki

Please specify how and where do you use this script and where do you see this error?

Executed from Linux command line:

$ documentbuilder sample.docbuilder

Sorry for the late response.

Please provide the version of Document Builder that you are using.
If possible, also share a document that you have troubles with. You can upload it to any cloud storage and share an external link.

Document Builder version:

  • v7.4.0.166
  • sdk version: 7.4.0 (build:166)

The document can be downloaded from but this happens with any other.

Thank you. Unfortunately, I wasn’t able to reproduce the issue.
Some additional information needed:

  • do you execute the command with sudo?
  • what OS are you running?
  • did you install the dependencies as per guide?

Using Ubuntu 23.04

I tried with sudo and worked. After than, with a regular user also worked.

I don’t understand why :face_with_raised_eyebrow:

Indeed, this is quite strange. Mind me asking if it is working correctly right now?

Yes, it’s working right now. It’s quite odd…