Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

[ERROR] While opening any document

I would like to: Report a bug
OS version: Windows 11 Pro x64
App version: Desktop Editors v 7.1.1.57 x64 & x86
Downloaded from: ONLYOFFICE website ONLYOFFICE desktop and mobile apps | ONLYOFFICE
Hardware: Core i5-7600K, 16GB RAM

Quick intro
Hello community.
I’ve been using the Desktop Editors for quite some time now. Today I installed it on another machine but I face the following issue, which prevents me from using it.

Bug description
The installation went through fine. When double clicking on the desktop icon “ONLYOFFICE Editors” the interface comes up fine. But when clicking on Document / Spreadsheet / Presentation (under Create new) to the left, the following things happen

  1. The relevant interface appears (for documents when I click Document, for spreadsheets when I click Spreadsheet, etc)
  2. The error appears: “An error has occurred while opening the file.” with an OK button below. After clicking OK, the message goes away, but there is nothing I can do with the interface, other than close the document.

The same happens when I double click a document of type .xlsx, docx, etc, or try to open such documents using the “Open local file” option.

Screen Recording Here is a short screen recording of the problem https://we.tl/t-cAZpFAVPrI

Expected behavior: I would expect that when I click “Create new > Document / Spreadsheet / Presentation”, or “Open local file” a usable interface would come up with no errors.

Things I tried but didn’t work:

  • Restart Windows
  • Uninstall Desktop Editors (clear all user settings) and reinstall
  • Try both x64 and x86 versions of Desktop Editors
  • Run dism /Online /Cleanup-Image /RestoreHealth && sfc /scannow and restart Windows

Hello @Felix
Please run a test:
Right click on shortcut >Properties > add this line to Target: --ascdesktop-support-debug-info

Please check my screenshot.

… > Apply > run Desktop Editors.

Now we have enabled console mode and we can check out error entries. Please reproduce the issue (try to create\open a file) and immediately hit F1 button. Please check Console and Network tabs and make screenshots.

@Alexandre hi and thank you very much for your message!

I followed your guide and here are the contents of the console tab:

api.js:1010 Unrecognized feature: 'display-capture'.
createIframe @ api.js:1010
[object%20HTMLCollection]:1 Failed to load resource: net::ERR_FILE_NOT_FOUND
/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/common/AllFonts.js:1867 Uncaught SyntaxError: Invalid or unexpected token
sdk-all.js:1224 Uncaught TypeError: Cannot read property 'length' of undefined
    at Object.a.AscCommon.vV.decode.a.AscCommon.vV.decode (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all.js:1224:455)
    at f (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all.js:1159:507)
    at Ja.nw (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all.js:1182:93)
    at Object.nw (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all.js:1186:267)
    at Yb.od.d8c (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all-min.js:1098:484)
    at Yb.d8c (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all-min.js:1407:377)
    at HTMLScriptElement.Fd (file:///C:/Program%20Files%20(/C:/Program%20Files%20(x86)/ONLYOFFICE/DesktopEditors/editors/web-apps/apps/api/documents/x86)/ONLYOFFICE/DesktopEditors/editors/sdkjs/word/sdk-all-min.js:1053:326)

Network tab didn’t have any contents

Hello @Felix
We just released Desktop Editors v.7.2. Could you please update your app and re-check the issue?

Getting the same error, updated to the latest version. Output from the error console:

Hello @Alexandre
I Just uninstalled previous version of ONLYOFFICE and checked the box to clear all user settings. Then I installed Version: 7.2.0 X64.

I get the same error: “An error has occurred while opening the file.” with an OK button below.

Here is the export of the console window:

api.js:993 Unrecognized feature: 'display-capture'.
createIframe @ api.js:993
[object%20HTMLCollection]:1 Failed to load resource: net::ERR_FILE_NOT_FOUND
AllFonts.js:1867 Uncaught SyntaxError: Invalid or unexpected token
sdk-all.js:1459 Uncaught TypeError: Cannot read property 'length' of undefined
    at Object.d.AscCommon.iU.decode.d.AscCommon.iU.decode (sdk-all.js:1459)
    at a (sdk-all.js:1370)
    at p.Uw (sdk-all.js:1390)
    at Object.Uw (sdk-all.js:1395)
    at Ma.cc.KDd (sdk-all-min.js:1162)
    at Ma.KDd (sdk-all-min.js:1488)
    at HTMLScriptElement.<anonymous> (sdk-all-min.js:1112)
d.AscCommon.iU.decode.d.AscCommon.iU.decode @ sdk-all.js:1459
a @ sdk-all.js:1370
Uw @ sdk-all.js:1390
Uw @ sdk-all.js:1395
cc.KDd @ sdk-all-min.js:1162
Ma.KDd @ sdk-all-min.js:1488
(anonymous) @ sdk-all-min.js:1112
sdk-all-min.js:1328 Uncaught TypeError: Cannot read property 'Wd' of null
    at Ma.$Ke (sdk-all-min.js:1328)
    at Ma.Bc (sdk-all-min.js:1292)
    at Ma.U1f (sdk-all-min.js:1332)
    at Ma.Ueb (sdk-all-min.js:1458)
    at F.DesktopOfflineAppDocumentEndLoad (sdk-all.js:13998)
    at index.html?_dc=0&lang=en-EN&frameEditorId=placeholder&parentOrigin=file://:1
Ma.$Ke @ sdk-all-min.js:1328
Bc @ sdk-all-min.js:1292
Ma.U1f @ sdk-all-min.js:1332
Ma.Ueb @ sdk-all-min.js:1458
F.DesktopOfflineAppDocumentEndLoad @ sdk-all.js:13998
(anonymous) @ index.html?_dc=0&lang=en-EN&frameEditorId=placeholder&parentOrigin=file://:1
sdk-all.js:14007 Uncaught TypeError: Cannot read property 'zsa' of null
    at F.DesktopOfflineAppDocumentSignatures (sdk-all.js:14007)
    at index.html?_dc=0&lang=en-EN&frameEditorId=placeholder&parentOrigin=file://:1
F.DesktopOfflineAppDocumentSignatures @ sdk-all.js:14007
(anonymous) @ index.html?_dc=0&lang=en-EN&frameEditorId=placeholder&parentOrigin=file://:1

Or a schreeshot if it helps more…

Hello @Felix and @SiJiL
We are checking the situation. @SiJiL please confirm that you use Desktop Editors v.7.2 on Windows too as topic starter describes.

Update. @Felix and @SiJiL please let us know if you have any antivirus app installed on your PCs.
Also please go to System > About > make screenshot of this page.
One more thing, we need a list of installed apps from your side. Please go to Control Panel\Programs\Programs and Features, sort by date so we see latest installed apps by date and make screenshots of installed apps.

Yes I’m using v7.2. Only antivirus is Windows Defender. I’ll get a program list later (it’s on my wife’s laptop), but there’s really not very much installed.