ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Error while downloading the document file to be converted.) (version


I hope somebody can help me with the following issue.

I set up a community-server on a vServer and am trying to connect it to my managed Nextcloud (Hetzer). When applying my credentials into the connector app I get the following error:

Error while downloading the document file to be converted.) (version

Nextcloud version: 25.0.5 / managed Nextcloud via Hetzer Storage Share
OnlyOffice Connector 7.8.0

Debian 11bullseye / Community-Server Version version / not firewall (for now) / wget to Nextcloud-server: ok

Here is what I have done so far:

  1. Installed Community Server via 1-Click / bash
    2 .Installed Cerbot / apt -y install certbot
  2. Installed SSL Cert / sudo bash /usr/bin/ mymail mydomain
  3. Tested integrated test example via https / sudo systemctl start ds-example
  4. Stopped integrated test example / sudo systemctl stop ds-example

When I am executing „bash /usr/bin/“ via ssh the cli gets stuck.

Can anybody help me (I have already invested some time into searching/google)?

Thank you!

[2023-05-18T07:44:32.557] [ERROR] [localhost] [conv_check_1980127143_docx] [userId] nodeJS - error downloadFile:url=https://nextclouddomain/apps/onlyoffice/empty?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhY3Rpb24iOiJlbXB0eSJ9.RnnVvYP96GcZ5shbsG8xcPwXIjpFUJrhV0y0x5zAd3Q;attempt=3;code:undefined;connect:undefined Error: Error response: statusCode:403; headers:{"server":"nginx","date":"Thu, 18 May 2023 07:44:32 GMT","content-type":"application/json; charset=utf-8","content-length":"32","connection":"keep-alive","set-cookie":["oc_sessionPassphrase=m%2Fd4OY1eWqmpzzud38F8DG3C7rATKFV2HfPUXQltNcG%2BtpFZQLJnE3UPqeHgEmsvCha8%2B425xk6Qu0hw%2FWl8O0BRo4j%2Bt%2FvWIEk3p1jvbFKa1Iu%2FfrAydAWRxyE%2F9A1y; path=/; secure; HttpOnly; SameSite=Lax","__Host-nc_sameSiteCookielax=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=lax","__Host-nc_sameSiteCookiestrict=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=strict","oc3kho7igs3o=ce37153e381e4a0671583e9c8b4a8d4a; path=/; secure; HttpOnly; SameSite=Lax"],"expires":"Thu, 19 Nov 1981 08:52:00 GMT","pragma":"no-cache","cache-control":"no-cache, no-store, must-revalidate","x-request-id":"Zn1S7eLrjd32Hd4WLgsO","content-security-policy":"default-src 'none';base-uri 'none';manifest-src 'self';frame-ancestors 'none'","feature-policy":"autoplay 'none';camera 'none';fullscreen 'none';geolocation 'none';microphone 'none';payment 'none'","x-robots-tag":"noindex, nofollow, noindex, nofollow","referrer-policy":"no-referrer","x-content-type-options":"nosniff","x-download-options":"noopen","x-frame-options":"SAMEORIGIN","x-permitted-cross-domain-policies":"none","x-xss-protection":"1; mode=block"};
    at Request.fResponse (/snapshot/server/build/server/Common/sources/utils.js)
    at Request.emit (events.js:400:28)
    at Request.onRequestResponse (/snapshot/server/build/server/Common/node_modules/request/request.js:1059:10)
    at ClientRequest.emit (events.js:400:28)
    at HTTPParser.parserOnIncomingClient (_http_client.js:647:27)
    at HTTPParser.parserOnHeadersComplete (_http_common.js:127:17)
    at TLSSocket.socketOnData (_http_client.js:515:22)
    at TLSSocket.emit (events.js:400:28)
    at addChunk (internal/streams/readable.js:293:12)
    at readableAddChunk (internal/streams/readable.js:267:9)
    at TLSSocket.Readable.push (internal/streams/readable.js:206:10)
    at TLSWrap.onStreamRead (internal/stream_base_commons.js:188:23)

Hello @Marko

Was it successful test? I mean in terms of ability to create/edit documents.

Please perform this procedure once more and share the output. Also check from next cloud to Document Server.

Try out also adding this to the <NC_root_directory/config/config.php of Nextcloud:

'onlyoffice' =>
array (
'jwt_secret' => '<your_key>',
'jwt_header' => 'AuthorizationJwt',

And after that connecting again.

Additionally visit https://<documentserver_address>/healthcheck and check its output.
Is there any proxy used in your environment?

Hello @Constantine,

thank you very much for your help.

Yes. I could create and edit documents.

Unfortunately, I can only test it from the community server, since the Nextcloud server is managed by a Hoster/Hetzner. I also have another community server as docker instance running/connecting just fine.

  • with another self hosted nextcloud I get the same error.
root@xxxx:~# wget https://nextclouddomain
--2023-05-18 10:34:57--  https://nextclouddomain/
Auflösen des Hostnamens nextclouddomain (nextclouddomain)… IP, IPv6
Verbindungsaufbau zu nextclouddomain (nextclouddomain)|IP|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 302 Found
Platz: https://nextclouddomain/login [folgend]
--2023-05-18 10:34:57--  https://nextclouddomain/login
Wiederverwendung der bestehenden Verbindung zu nextclouddomain:443.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 14650 (14K) [text/html]
Wird in »index.html.1« gespeichert.

index.html.1        100%[===================>]  14,31K  --.-KB/s    in 0,002s  

2023-05-18 10:34:57 (5,87 MB/s) - »index.html.1« gespeichert [14650/14650]

Can#t do this either on the managed Nextcloud :frowning:

Output = true, no proxy

Thank you Constantine

Try changing JWT token header to Authorization in /etc/onlyoffice/documentserver/local.json config of Document Server:

        "inbox": {
          "header": "Authorization",
        "outbox": {
          "header": "Authorization",

After that restart Document Server services with systemctl restart ds-* to apply the change and try connecting again.

As a reference check the header in that installation.


Holy cow, it worked!

Thank you so much, you have saved my week, literally!


1 Like

I’m glad to help.