ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Error while connecting Docs and NextCloud

Hi guys!

I’ve tried to connect NextCloud 22 to OnlyOffice Docs. I already installed connector from NC AppMarket.
Then I modified default.json and add secret >
“secret”: {
“browser”: {“string”: “Cloudsecret”, “file”: “”, “tenants”: {}},
“inbox”: {“string”: “Cloudsecret”, “file”: “”, “tenants”: {}},
“outbox”: {“string”: “Cloudsecret”, “file”: “”},
“session”: {“string”: “Cloudsecret”, “file”: “”}
},

On NextCloud I modofied config.php >
‘onlyoffice’ =>
array (
‘verify_peer_off’ => true,
),
‘allow_local_remote_servers’ => true,
and added trusted domain domain name and ip of Docs server.

While trying connect Docs to NC I get error “Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version 6.4.2.6)”

Does somebody know how to fix?

Upd. Docs server switched to use HTTPS on 443 port, on NC disabled certificate verification

Hello,

JWT settings for the Document Server are enabled in local.json config, not default.json.
Please do that and if the issue persists, provide Document Server logs from /var/log/onlyoffice/documentserver/

No, in local.json JWT is disabled.
“inbox”: {
“header”: “Authorization”
},
“outbox”: {
“header”: “Authorization”
}
and one more question have I change secret in local.json?

about logs, /var/log/onlyoffice/documentserver/converter/out.log
Error: getaddrinfo ENOTFOUND cloud.mydomain.kz

  • at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:56:26)*
    [2021-11-01T05:41:13.262] [ERROR] nodeJS - checkIpFilter error:url=https://cloud.mydomain.kz/index.php/apps/onlyoffice/empty?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhY3Rpb24iOiJlbXB0eSJ9.3B6Pi9Ucr4DLw2wev7HL8kqh-PsSM8gcGz5zvIPDnPY;code:403;(id=conv_check_445336383_docx)
    [2021-11-01T05:47:15.612] [ERROR] nodeJS - dnsLookup error: hostname = cloud.kazteleport.kz

After that, I added to hosts file record of cloud.mydomain.kz

in /var/log/onlyoffice/documentserver/docservice/out.log
2021-11-01T05:38:54.115] [WARN] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. File system | Node.js v17.0.1 Documentation
[2021-11-01T05:38:54.159] [WARN] nodeJS - Express server listening on port 8000 in production-linux mode. Version: 6.4.2. Build: 6

Hi I get this error:


I am running nextcloud 23.0.2 running on unraid 6.9

I found a thread also talking about changing the local.json file.
I added this line:
},
“inbox”: {
“header”: “AuthorizationJwt”
},
“outbox”: {
“header”: “Authorization”

but that did not help.

Maybe you can explain in more detail what I need to change in which file exactly. That would help me a lot.

Hi geefle. Sorry for a long response, but I solve the problem. It was on OO side.
You have to edit local.json file > edit false (standart value) to true

 "token": {
        "enable": {
          "request": {
            "inbox": true,
            "outbox": true
          },
          "browser": true

Thank you. That did something. Now I get the error that I have an invalid token. I set a character string in the Nextcloud settings page for only office. That did not help. Where do I get/set that token?

Hello @geefle
If you disabled token in local.json file, please make sure that it is disabled on Nextcloud side too (connector app page). If it doesn’t help, please provide us with your local.json file and logs folder.