Error downloading file. Press “OK” to return to documents list


Aftter restoring a backup in control pannel, I’ve started getting this error now: Error downloading file. Press “OK” to return to documents list."

It does happen when I try to open any document from the browser or from the windows app (OnlyOffice WS Community Server, running under Ubuntu Server 22.04).

Thanks in advance guys :wink:

  1. log files from /var/logs/onlyoffice/communityserver and var /logs/onlyoffice/documentserver inside the containers - where do I get these from?

Is it?

  1. screenshots of the Console and Network tabs of the browser console while reproducing this issue.

Hello @brunoleonadvogado
What are current components versions of your portal (Document server, Community server, etc.)? Also let us know your installation type (docker, packages).
Also please go to portal settings > Integration > Document server > click Save button and make a screenshot of the result (whole page).

Hi Alexandre,

  1. Versions: it’s on their latest versions, as I just reinstalled Workstation on another pc and restored the backup;

  1. Instalation: I did use the script .sh from your website, and selected the docker installation;

  2. Integration: When I try to use my domain setings a get this error:

If I use the default settings, I get a successful message, but the problem persists in both cases:

  1. As a piece of information, if I try to download any document directly, I get this screen:

Hello @brunoleonadvogado
Sorry for the late reply.

Please clarify if your old portal had the same components versions as the new one (I mean Control Panel version, Community server version, etc.)
A few more things.

  1. Please run a test.
    Go to Community Server container and open file /var/www/onlyoffice/WebStudio/Web.config . Find <customErrors mode=“On” and set value “Off”.
    Run service monoserve restart inside of container.
    After you disabled customErrors mode in the configuration file there will be the detailed description of the error in web interface when it recurs the next time. Please send us the screenshot of this error description.

  2. Did you encrypt data via Control Panel on the old portal?

  3. Please try to create a new file. Will the issue reproduce?

  4. Is it possible to provide us with your portal backup file? This way we will try to restore it on our test server and check out the situation. If so, please contact me via PM.

Yes Alexandre, all the same, I have used the same installation script as before.

  1. I can’t run the tests anymore as I redone everything;

  2. I did not encrypt data;

  3. I could upload files normally, but not download them, I did not try creating;

  4. Well, the problem is solved now and here are my finds:

a) I’ve installed a fresh ubuntu server, and run your .sh script, but this time with the machinekey command (as I believed that this was my mistake the first time);

b) This time my branding images were recovered automatically (so maybe the first time it failed partially, but I had no clue). Anway I had to create a new password, is it not what the machinekey shoud address?

c) It’s now fully working, and smoothly. Only small detail is that I had to run the script to enable “https” from the terminal, as the control panel one didn’t work.

Thank’s for your assistance, Alexandre.

Hello @brunoleonadvogado
We are glad that the issue is solved. But it’s a little bit strange that you had successful authorization on the restored portal without machinekey parameter in your first test.
Anyway, please feel free to contact us if you face any issues.

Strange, yes. Except for the branding images and the acces to the documents, everything else was there.

It’s true that at first I could not get into the portal, but as I requested a new password, I did get in.

Thank you Alexandre, learning everyday :slight_smile:

1 Like