Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Email is not received (IMAP)

Community Server: 12.0.1142
Control Panel version: 3.1.401
Type of installation of Workspace (docker, deb/rpm, exe)
OS: Windows Server 2019
Browser version: Chrome aktuell

After upgrading to version 12 Community Server, receiving emails no longer works. No synchronization IMAP. In settings the connection shows no errors. Capture, save and send e-mails - without any problems. Only reception (new mail) does not work. Please help me.

/No own email server. The mail accounts run fully functional with the provider and in all other clients (postboxes, etc.)./

1 Like

Here my server also fails, I do not have configured mail server, but accounts within mail to be able to receive by IMAP the mail of my business mail server, it only works with POP but does not receive any mail. What can happen? We have certificate in the domain, in the mail server, etc.

My server is self-hosted on Linux with automatic installation script with the entire package complete workspace (integrates mail server but is not configured), my mail provider is under Plesk with an imap/pop server with Courier (you can also change to Dovecot) and other mail clients receive by imap, with Onlyoffice you do not receive anything in the entry, but if you send correctly over SMTP.

It is only due to the new version 12 (old version works without problem):
MailAggregator does not fetch the mails from the mail server. (I also tried an account via POP-3, the same effect: e-mails sent yes, received no. I tried to find logs (e-mail synchronization), but I don’t know where to look.

It did not work for us with the previous version either, so it was difficult to bet on a paid version, but seeing that you had an error like ours, support the sending of messages to see if there are solutions currently.

Hello @Prof_h_c_K_Krause and @Nexus
I think we have to take a look at your Community server logs. Please provide us with them. They are located here:
Windows: Program Files (x86)\Ascensio System SIA\CommunityServer\Logs
Docker: /app/onlyoffice/CommunityServer/logs/

1 Like

Hello, Alexandre
attached are my logs (errors). Please see what can happen with the MailAggregator.
Archive .zip Logs
Thanks in advance

Hello, the log I attach it. We also have another problem sometimes, it is the following: when we connect a cloud such as Dropbox or Google Drive in some user accounts, the login is done correctly but the directory does not stay with the folder tree below “documents” and we have seen that this happens with accounts that the server had before and a data restoration was done. Thanks for everything, greetings. LOGS

Thank you for provided logs. We are looking into them. Meanwhile, have you tried to restart MailAggregator service?
For Windows server it’s ONLYOFFICE Mail in Windows Services. For Linux: service onlyofficeMailAggregator restart (inside Community server container).

One important note. Do I understand right that you don’t use ONLYOFFICE Mail server?
Also please let us know OS version and point us to how exactly you have installed\updated portal (point us to the guides which you used)

@Nexus I believe it’s better to move additional issue to a separate topic. Please create a new one and attach videofile with issue scenario.

Dear Alexandre

  1. Sure, I’ve tried restarting the services. I also tried a few times to start the system completely (Windows).

  2. Installation on Windows 2019. I had earlier Community Server version 11.6.1035 in my Windows machine. After the message in the control panel about the new version 12.0.1142, I loaded it. The installation took a long time but ran without error messages. After installation, Community Server was restarted. All functions as far as I checked, like CMR, documents, projects, personnel, without errors. Only e-mail is not received, although no error message has gone.

  1. My portal has been running on a virtual machine (Virtual Box) since 2020. So that I can easily get a clean installation through security points, I also tried to install version 12 a second time. In this case, too, everything was clean, except for the mail function.
  2. E-mail settings: I have accounts on a third-party server (host) where my website runs. Sure, I entered the accounts in Onlyoffice with IMAP /SSL synchronization. When I tried to register a new account in Onlyoffice, it was also confirmed with no problem registered with host (mail server) and connection. But e-mails are not picked up or received by Onlyoffice from the new account either. A second attempt with POP-3 synchronization has the same effect.

"747 ERROR [50] ASC.Mail.MainThread - IsQuotaExhausted(Tenant=1) Exception: Input string was not in a correct format."
I see this message in the error log every time I try to update mailboxes.

I suspect an error in the installation program that entered something incorrectly in the DB or interpreted it incorrectly. I can also access and correct tables in MySql if I know what I need to change.

Dear Alexandre
I’m guessing this is a folder tree in my email tab.
It should also be included in the data area of the community servers when installing version 12. It may be that some requests are incorrect.

REKO-WEB 2022-05-31 17-05-37

Hi Alexandre, yes, I have also restarted the server several times and it does not work. I can’t restart the service anyway, this shows me the terminal (I have a very basic level of Linux, no level in docker) Failed to restart onlyofficeMailAggregator.service: Unit onlyofficeMailAggregator.service not found. The server installation was done with this guide:
https://helpcenter.onlyoffice.com/installation/workspace-install-docker.aspx
and these commands :
wget https://download.onlyoffice.com/install/workspace-install.sh
sudo bash workspace-install.sh -md nube.mydomain.es
Then it’s all automatic, but I didn’t know that I didn’t need OnlyOffice Mail Server to only use IMAP and use OnlyOffice Mail as a module.
I remember also installing the Windows version and not getting the download to work by IMAP, the SMTP service if it works and sends the emails.

As an additional fact, if I connect a GMail account, the download, sending and synchronization works correctly, the Mail module if it works with this provider, why does not my account? My third-party server has SSL certificates, my domain mail supports SSL/TLS, and the OnlyOffice Workspace server also has LEts Encrypt.
Thanks for everything, greetings.

@Nexus
Please go to the host and run lsb_release -a
Please show me the result.
For MailAggregator restart you have to go inside Community server container. Please follow my steps:
docker ps - check Community server ID
docker exec -it *ID* bash
service onlyofficeMailAggregator restart

Also please check your PM, I sent your an additional message yesterday.

@Prof_h_c_K_Krause
Thank you for provided information.
We assume that the issue which you have been facing is related to one of third-party libraries which MailAggregator uses.
We have started working on a fix for this issue.
Unfortunately, I cannot provide you with exact timeframes of hotfix release. But we will try to do it as soon as possible.

@Nexus
Without requested earlier information I can’t check if you have the same issue as @Prof_h_c_K_Krause , so we are looking forward to information from your side.

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.4 LTS
Release: 20.04
Codename: focal

Alexander, thank you for the steps to restart a service in a Docker, although unfortunately nothing has happened and the reception of messages by IMAP has not worked. So I will follow your new steps from yesterday’s email to be able to send you more data. Thanks in advance, very kind.