ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

Editor does not load large document from cloud

ONLYOFFICE cloud: Free / Personal
Do you want to: Report a bug / Ask a how-to question
Browser version: Firefox v91.0.1 / ONLYOFFICE Desktop Editors v6.3.1.56 on Windows 10 20H2

When trying to open large text document (over 500kB) hosted on OO cloud or Google Drive, I receive “failed to load document” error both in web-app and in desktop.

OO desktop app, LibreOffice open identical local file without an issue, Google Docs works fine with it on its native cloud.

Снимок1

Hello,

Thank you for your request!

We have checked the personal cloud and Google Drive connected to the cloud through the web editor and desktop editor and found no problems.

Please let us know if the problem persists.

Best regards,

Problem persists, yes. Sorry for not replying sooner. Maybe the issue is in converting Google doc formatting to onlyoffice’s XML type (or not doing that at all before trying to open it)? Couldn’t replicate this issue with any other document.

I’ve tried uploading file directly to personal cloud and it opened correctly. Opening this document from GDrive or its copy imported from there to personal cloud is still not working.

That is a possible workaround, but that does not solve my need to have local editor for google documents.

Hello,

Please send us the file with which the problem occurs - attach it to the message - if the file does not contain confidential information.

Best regards,

Unfortunately it is confidential, as it is a commercial project. I do not mind providing it by non-public means for testing purposes, though. Do you have any private communication channel for that? You also may email me directly.

Also, if that will help, when trying to download file in question from personal cloud or from GDrive through onlyoffice cloud interface, i receive this error message on unability to read original file:
Снимок3

No such issue happened with other files yet.

While it’s not clarified yet how exactly you could transfer the file to us, you can try to create a copy of the file, removing all confidential information. If the error persists with it, please send it to us.