E: Unable to locate package onlyoffice-documentserver (Install Documentserver Debian 12 (Proxmox VM))

Hi guys, I have set up an empty Debian 12 VM on a Proxmox server. I have followed all the steps in the instructions.


I was able to install all necessary packages without any problems
When installing onlyoffice-documentserver the message appears:

E: Unable to locate package onlyoffice-documentserver

GPG is correct
apt-get update and upgrade was performed
vm was restarted
ping on download.onlyoffice.com goes

I have the same error when i use the docs-install.sh script

Where is my fault?

Thank you

I have entered all the necessary commands in this order.

  • sudo apt-get install -y redis-server rabbitmq-server nginx-extras gnupg2 htop curl

  • sudo apt-get install -y postgresql

  • systemctl enable postgresql

  • systemctl start postgresql

  • sudo -i -u postgres psql -c “CREATE USER onlyoffice WITH PASSWORD ‘onlyoffice’;”

  • sudo -i -u postgres psql -c “CREATE DATABASE onlyoffice OWNER onlyoffice;”

  • sudo -i -u postgres psql -c “GRANT ALL privileges ON DATABASE onlyoffice TO onlyoffice;”

  • mkdir -p -m 700 ~/.gnupg

  • curl -fsSL https://download.onlyoffice.com/GPG-KEY-ONLYOFFICE | gpg --no-default-keyring --keyring gnupg-ring:/tmp/onlyoffice.gpg --import

  • chmod 644 /tmp/onlyoffice.gpg

  • sudo chown root:root /tmp/onlyoffice.gpg

  • sudo mv /tmp/onlyoffice.gpg /usr/share/keyrings/onlyoffice.gpg

  • echo “deb [signed-by=/usr/share/keyrings/onlyoffice.gpg] https://download.onlyoffice.com/repo/debian squeeze main” | sudo tee /etc/apt/sources.list.d/onlyoffice.list

  • sudo apt-get update

  • sudo apt-get upgrade

  • sed -r -i ‘s/^deb(.*)$/deb\1 contrib/g’ /etc/apt/sources.list

  • sudo apt-get install -y ttf-mscorefonts-installer

  • sudo apt-get install -y onlyoffice-documentserver

Hi @inputbox :wave:

Could you please confirm which architecture you are using for Debian 12? Is it ARM or x64 (amd64)?

Your approach appears to be correct. Could you also specify which installation guide you followed?

It’s a x64 System on a Intel CPU (Virtual CPU Emulation Typ: x86-64-v2-AES)
Vitrtual HDD: 60GB
1 Socket, 2 Cores


  1. Check if the repository is added correctly (please send the command output):

    cat /etc/apt/sources.list.d/onlyoffice.list

    You should see:

    deb [signed-by=/usr/share/keyrings/onlyoffice.gpg] https://download.onlyoffice.com/repo/debian squeeze main
  2. Try running the commands manually to update the package list and search (please send the command output):

    sudo apt-get update
    apt-cache search onlyoffice-documentserver
  3. Ensure the GPG key is installed correctly (please send the command output):

    gpg --list-keys --keyring /usr/share/keyrings/onlyoffice.gpg

    You should see information about the ONLYOFFICE key.

My Outputs:

deb [signed-by=/usr/share/keyrings/onlyoffice.gpg] https://download.onlyoffice.com/repo/debian squeeze main

OK:1 http://deb.debian.org/debian bookworm InRelease
OK:2 http://security.debian.org/debian-security bookworm-security InRelease    
OK:3 http://deb.debian.org/debian bookworm-updates InRelease                   
OK:4 https://download.onlyoffice.com/repo/debian squeeze InRelease

apt-cache: no output

pub   rsa4096 2016-12-15 [SC]
uid        [ unknown ] Ascensio System Limited (ONLYOFFICE) <support@onlyoffice.com>
sub   rsa4096 2016-12-15 [E]
1 Like


Are you still encountering the error when running the command:

sudo apt-get install onlyoffice-documentserver

Yes, its the same Error.

I have already reinstalled the system several times,
even with install script the error appears.


It looks like your issue might be related to AptPreferences specified in the file /etc/apt/preferences or in the directory /etc/apt/preferences.d/.

To check the priority of the repositories, you can run the following command:

apt-cache policy

The Priority of all Package Sources is 500.

Hmm :roll_eyes:

Please provide the output of the following commands:

apt-cache policy
apt-cache policy onlyoffice-documentserver

apt-cache policy:
100 /var/lib/dpkg/status
release a=now
500 https://download.onlyoffice.com/repo/debian squeeze/main i386 Packages
release o=debian squeeze,a=squeeze,n=squeeze,l=debian squeeze,c=main,b=i386
origin download.onlyoffice.com
500 Index of /debian bookworm-updates/main i386 Packages
release v=12-updates,o=Debian,a=stable-updates,n=bookworm-updates,l=Debian,c=main,b=i386
origin deb.debian.org
500 Index of /debian-security bookworm-security/non-free-firmware i386 Packages
release v=12,o=Debian,a=stable-security,n=bookworm-security,l=Debian-Security,c=non-free-firmware,b=i386
origin security.debian.org
500 Index of /debian-security bookworm-security/main i386 Packages
release v=12,o=Debian,a=stable-security,n=bookworm-security,l=Debian-Security,c=main,b=i386
origin security.debian.org
500 Index of /debian bookworm/contrib i386 Packages
release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=contrib,b=i386
origin deb.debian.org
500 Index of /debian bookworm/non-free-firmware i386 Packages
release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=non-free-firmware,b=i386
origin deb.debian.org
500 Index of /debian bookworm/main i386 Packages
release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=main,b=i386
origin deb.debian.org

apt-cache policy onlyoffice-documentserver:
N: Couldn’t find package onlyoffice-documentserver

1 Like

We overlooked the most crucial detail.
I figured out the CPU architecture, but OS architecture…

ONLYOFFICE Docs Community Edition for Linux System Requirements:

Software requirements:

CPU: dual core 2 GHz or better
RAM: at least 2 GB, but depends of the host OS. More is better
HDD: at least 40 GB of free space
SWAP: at least 4 GB, but depends of the host OS. More is better
OS: 64-bit Debian, Ubuntu or other compatible distribution with kernel version 3.13 or later

Oh no, how embarrassing, I overlooked that. :weary:
With the x64 version it works without any problems.

Great Job. Thank’s :smiling_face_with_three_hearts:

1 Like