Download Failed from laravel

Hello everyone
I installed the onlyoffice/documentserver on a linux 20.04 LTS server to have access to the api.

Now I’m trying to open it in my laravel project but I get errors that I can’t fix.

Thanks in advance for your help.

Hello @Ornice
I believe we have to check out Document server logs first. They’re located here:
docker: /app/onlyoffice/DocumentServer/logs/documentserver/
deb\rpm: /var/log/onlyoffice/documentserver/

By the way, please point me to the guide which you used for Document server installation and version of the installed app.
About Laravel in general. We don’t have ready-to-go integration examples for Laravel, but as far as I understand, the Laravel is PHP-based solution, so our PHP example (ONLYOFFICE Api Documentation - Example) probably will be useful in your research.

Thanks Alexandre.

For the guide, I used the linux installation guide available at onlyoffice/documentserver.

I used the following Basic example:

Yes, Laravel is based on php, which is why I was able to try the basic formula to begin with.
I also have an instance on Angular that returns the same errors

I already have my onlyoffice/documentserver deployed on a linux remote server so I use the
https://xxxxxxxxxx/web-apps/apps/api/documents/api.js for integration. I don’t want it local by the way.


Hello @Ornice

I’d like to join this thread.

Main reasons of these issues are desribed here:

For further assistance, we surely have to take a look at the logs of Document Server as my colleague suggests:

I might misunderstand but if you are using this address for integration in your apps as Document Server address, then this is wrong. Proper address is just https://<documennt_server_address/ without any additional info.

Thank you very much @Constantine and @Alexandre , problem solved.

1 Like

Glad to hear that it is solved now!

How did you solve this and would like you to do a tutorial on Laravel.

Hello @okellogabriel

If you are facing the same issue, please provide initial information about your environment:

  • version of Document Server;
  • installation type of Document Server (Docker, DEB/RPM packages, EXE/MSI);
  • version of Laravel;
  • your initialization config to run editors;
  • logs of Document Server after reproducing the issue.

Logs are located in C:\Program Files\ONLYOFFICE\DocumentServer\Log\ for Windows or in /var/log/onlyoffice/documentserver/ for Linux (same path for Docker inside container.

If your case differs, please consider creating separate topic on that.