ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

Document server not working in docker, error log says nginx error web browser says error 400

Do you want to: get document server working with nextcloud
Document Server version: 6.3- downgraded but problem persists to current version
Type of installation of the Document Server: docker
OS: unraid
Browser version: google chrome v95

have been having problems with nextcloud, found my documents portion was caused by the docker image i was using (chvb’s repository) witch is over a year old and V5 something, googling said its not supported in nextcloud onlyoffice client anymore, switched dockers to swiat2545 (witch appears to pull from the onlyoffice repository anyway) and followed spaceinvaderone’s video (again as i had to initially install onlyoffice). everything apears to work as the docker log followes startup and doesnt quit but displays “/var/log/onlyoffice/documentserver/nginx.error.log” in red and that log file displays just one line displaying this 2021/05/04 03:40:51 [error] 1027#1027: *5 upstream prematurely closed connection while reading response header from upstream, client: 172.18.0.2, server: , request: “POST /ConvertService.ashx HTTP/1.1”, upstream: “http://127.0.0.1:8000/ConvertService.ashx”, host: “onlyoffice.joe-joe.space”.
nextcloud displays either error 504 or error 400 when connecting and in browser if i go to my url it displays error 400, is i try the ip address directly it also says error 400. please help as i cannot for the life of me figure this out, multiple posts elsewhere say to try downgrading so i tried that and still get the same error

Hello,
I’m not aware of either of these guides so I would strongly recommend following our official guides and pull the images from our official repos:
https://helpcenter.onlyoffice.com/installation/docs-community-index.aspx