ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Document server is not working

Community Server/Control Panel version:
Type of installation of Workspace: deb/rpm
OS: ubuntu 22.04
Browser version: chrome

when I try to edit a document by clicking on the pencil
"document server " starts, flashes for about a minute then an error message appears as in the attachment
“the connection to the server was interrupted. please reload the page. click on “ok” to return to the documents list”
also the connection to the control panel no longer works (error 402)
below is the settings configuration page

Hello @romapao

The address of Document Service looks odd, usually such IPs are used for intranet.
Did you any changes to this page before? Have you tried resetting these settings?

Please make a screenshot of the browser console upon opening any file for editing.

I created a new ubuntu 22.04 VM and installed a fresh version of OnlyOffice Workspace Community using the script
“bash -it WORKSPACE”
i restored the backup (from the old server)
everything seemed to work fine but this morning the problem returned

  1. does not open the documents in web editing
  2. the control panel no longer works (error 402)
  3. I can’t change the setting of the Location of the attached document service the error to change these values I have to act on the web.appsettings.config file

I see that no one is answering me… maybe this problem hasn’t happened to anyone… I would like to try to solve it on my own… can you help me understand where the logs are located if I can go and investigate the causes?

I have found that the 502 bad gateway error also occurs when I convert a file for example doc → docx

Thank you

Hello @romapao

Please visit Document Server page to check its functionality by adding /ds-vpath/ to the address of your portal like that http://<portal_address/ds-vpath/ and share a screenshot of this page.

Also, specify if you perform host server restart before this issue comes up.
Share next logs for analysis:

  • of Community Server from /var/log/onlyoffice/communityserver;
  • of Document Server from /var/log/onlyoffice/documentserver.

Additionally, please check Document Server services status with systemctl list-units | grep ds and share an output of this command.

hallo Costantine

  1. /var/log/onlyoffice/communityserver
    I have neither folder nor file with the name communityserver in /var/log/onlyoffice/

  2. /var/log/onlyoffice/documentserver
    it is a folder
    contain 3 folders
    converter, docservice and metrics
    and 2 file
    nginx.error.log and nginx.error.log-20230331
    what do you need?

roxor@portal:~$ systemctl list-units | grep ds
run-credentials-systemd\x2dsysusers.service.mount loaded active mounted /run/credentials/systemd-sysusers.service
ds-converter.service loaded activating auto-restart Docs Converter
ds-docservice.service loaded activating auto-restart Docs Docservice
ds-metrics.service loaded activating auto-restart Docs Metrics

Hello @romapao

Sorry for the late response.

After resetting Document Service settings to default ones, press the Save button and then check the situation again.
If the issue reproduces, please share whole /onlyoffice/ catalog from /var/log/ for analysis. You can send it to me via PM in term if safety.

whereas I think the problem occurs only after installing the letsencrypt certificate.
and that the community server can be reached at the following url
which of the two attached screenshots is in your opinion the right one?

consider however that I have tried both configurations with the same result
moreover, to modify these parameters I have to act only on the file /var/www/onlyoffice/WebStudio/web.appsettings.config

if I try to make changes from the form and click on the save button I get this error:
“Healthcheck url: The remote server returned an error: (502) Bad Gateway.”

I’m sending you a PM with the zip of the onlyoffice folder in /var/log/

Hello @romapao

Thanks for the logs, we are analyzing it.
Meanwhile, please describe how exactly you are installing certificates to enable HTTPS. If used any guide, share it with us.

Please also try following the instruction that my colleague provided in similar thread:

I used this command
sudo bash /usr/bin/

it would appear that changing the owner to the logs worked

Glad to hear that it works now. This issue is related to the bug 61600, which will be fixed in the next version of Community Server.
Accept our apologies for the inconvenience caused.