ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Disable full-text search from command line

I have installed onlyoffice-communityserver manually on a Ubuntu 22.04 virtual machine, currently with 2 CPU, 6GB of RAM, and 50GB of storage, by following the guide at Installing ONLYOFFICE Groups for Debian, Ubuntu, and derivatives - ONLYOFFICE. For the most part, this has worked great. However, elasticsearch is pegging my CPU and is frequently shut down by the OS, which mean I can’t access the control panel. I tried modifying the JVM options to use less RAM, which worked for a bit, but not ideal.

What I would like to do is just disable full-text searching entirely and bypass the need for elasticsearch in the first place. I don’t need that feature, and it is certainly not worth the resources that elasticsearch needs to run. However, the guides only tell me how to disable full-text search using the control panel, but I can’t access the control panel without getting elasticsearch to run.

How can I disable full-text search from the command line, so that the control panel will load without elasticsearch running? I still would like the backup/restore and other control panel features. I’m hoping there’s a configuration file somewhere to control this.

Thank you for any help you can provide.

Edit: I just remembered that this also causes issues during installation. I get the error:

Job for elasticsearch.service failed because a timeout was exceeded.
See "systemctl status elasticsearch.service" and "journalctl -xeu elasticsearch.service" for details.
dpkg: error processing package onlyoffice-communityserver (--configure):
 installed onlyoffice-communityserver package post-installation script subprocess returned error exit status 1

which prevents the package from being installed successfully. To finish installing, I have to get elasticsearch running again, then re-run the install or reconfigure. This has made installations quite annoying and slow.

Edit: I finally got the control panel to load, and it looks like full-text search is not enabled by default. Now I’m wondering, why does control panel fail to load when elasticsearch is down if elasticsearch isn’t even being used? Either way, my request remains the same, which is the ability to run onlyoffice without elasticsearch.

Hello @ps_iclimbthings

Elasticsearch in ONLYOFFICE Groups is used for the search throughout the whole portal, not only for Full-Text Search feature. Disabling Elasticsearch will heavily affect searching performance and capabilities.

If you still want to disable it then execute service elasticsearch stop command.
In case you want it to remain disabled after a system reboot then execute next commands too:
systemctl disable elasticsearch.service
rm -f /usr/lib/systemd/system/elasticsearch.service
rm -f /etc/init.d/elasticsearch

Also, I’ve noted that you are running Groups on the server with characteristics that are close to the minimal requirements. As another solution you can try running Groups on the server with better specs.

1 Like

Thanks for the info, that’s good to know. I discovered today as well as you mentioned that I can disable elasticsearch after the control panel has been configured without adverse affect. I suppose elasticsearch is only needed for initial setup for the first time the control panel loads, but then after that can be safely disabled.

Well, yes, you are right.
Let me know if you have other questions.