ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

Desktop app: cannot change font in titles, content

Document Server version: n/a, ONLYOFFICE Desktop Editors version 6.3.1.56
Type of installation of the Document Server (docker, deb/rpm, exe) : n/a
OS: Manjaro Linux 21.1
Browser version: Firefox 91.0.2

Hi Community,

I’ve just opened a .docx document, created with the latest Word app on a Windows machine. I want to change the default font of the document:

  • Selected some text at the very beginning of the doc and changed the font from Arial to other = test OK.
  • Then selected the whole content and tried to change the font as well = KO, the font is still Arial, whether it’s titles or content!

I can’t see any difference between the lines that changed and the lines that refused to change… :thinking:

Any help would be greatly appreciated!

Hello jlgarnier.

Could you please provide us with an example of the file where the issue is reproducible and describe step-by-step issue scenario (you can make screenshots or a videofile)? I tried to reproduce the situation with file created in MS Word 2019, but font changes smoothly.

Also please let us know exact version of MS Word where your file was created.

Hi Alexandre and thanks for the quick answer!

I don’t remember the exact Word version on my Windows machine (I’m not home) but it’s the very last Office 365 version (automatic Office update on the Win10 machine).

Is there any way to send a file through the forum as an attachment?

By the way, the issue is pretty easy to reproduce: just open the file (when you’ll get it :wink:):

  • Try to change the font on any text before the first title item (“Description du projet”) = OK
  • Try to change the font on / after the first title item = KO, keeps Arial font.

Maybe OnlyOffice doesn’t recognize some tag into the original file…

Thanks again for your help, waiting for a way to send the file!

Hello @jlgarnier.
You can upload the file to some external storage and provide us with download link.

Here you have: Loading Google Docs

Thanks for your help!

Thank you for provided file. We were able to reproduce the issue. We added a bug to our internal tracksystem (bug number - 52678). We are going to fix it.
Thank you for valuable data.

Wasn’t a big deal! You deserve the thank you for this great job and this fantastic tool you gave us! Glad to help with some minor issues! :clap: :clap:

1 Like