Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

CSV file not parsed properly (v 7.2.0.204)

Windows version: 7.2.0.204 (64 bit exe package)
Windows OS 10 22H1

I have a simple comma delimited file that is opened in OnlyOffice spreadsheet, but the 2nd token is not parsing properly. Each row of the file has only 3 tokens. The 2nd token is for “data amount”. So it has units of KB and MB in the text (e.g “345 KB”).

---- start of CSV file ----

Date,Data Amount,Charge
10/15/2022,345 KB,0
10/14/2022,5 KB,0
10/13/2022,3.6 MB,0
10/8/2022,735 KB,0
10/7/2022,415 KB,0
10/6/2022,4.3 MB,0
10/3/2022,20 KB,0
10/1/2022,2.3 MB,0

— end of CSV file ------

It is displaying properly in the spreadsheet in three columns, but when I click on the cell of 2nd column it shows the value without the “KB” or “MB” in the formula location. (see pic 1)

It looks like OnlyOffice is stripping off “KB” and "MB’, and is displaying it via custom number formatting (see pic 2). I did not create that custom number format.

How do I stop OnlyOffice from doing custom formatting on that 2nd column? I just want the full text of the 2nd token; i.e. value of “345 KB” and not “345”.

pic1
image

pic2
<I am a new user. So I can only post one image. 2nd pic will be in the first reply below>

pic 2
image

Hello @lego-blockhead
Please provide us with mentioned CSV file. You can place it to any external storage and send us download link. Do I understand it right that usage scenario is importing CSV file to spreadsheet editor via ‘Get data’ option?

Thank you @Alexandre for replying to my post. I have uploaded the file to the drop box link below.

The way I open the file in Onlyoffice desktop editor is not via “get data” option. I just use “open local file” and the file is on my local HDD. Then the dialog in the pic below is displayed. I select “comma” as the delimiter.

image

I just tried opening a blank spreadsheet, and then use “get data”. This method did not cause the problem I reported; i.e. it works as expected. Thank you for providing me an alternative to opening this file properly.

We are glad that the situation is solved. But we are going to check provided file and original scenario anyway. I’ll update this thread when we have something to share.

Hello @lego-blockhead
We have checked your original issue scenario and we added a bug to internal tracksystem (internal number - 59504). We have started working on it.
Thank you for the file and your description!