Need dedicated support? Click here
Need dedicated support?
Click here

Control Panel onlyoffice workspace return home page

Do you want to: Suggest a feature / Report a bug / Ask a how-to question
For feature suggestions, describe the result you would like to achieve in detail:
For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem:

I installed community version in my own server, everythin working but i lost the control panel . when i try to access control panel i got the homepage

Community Server/Control Panel version:
Type of installation of Workspace (docker, deb/rpm, exe)
OS: ubuntu 22.10
Browser version: google chrome

Hello @jules_diedhiou

Please specify the guide that you’ve followed to install Workspace for better understanding.

Hi @Constantine
I followed this guide : Installing ONLYOFFICE Workspace


Please execute apt list --installed | grep onlyoffice command and share the output.

Additionally, record a video demonstration of the issue according to this scenario:

  1. Before reproducing the issue, open browser console (F12);
  2. Open Network tab of browser console;
  3. Reload the page with opened browser console;
  4. Open Control Panel to reproduce the issue.
  5. Once redirected, demonstrate any error entries from Console tab of browser console too.

Thanks you

  1. the command output

  2. the record video
    video recorder

Thank you for the info.
Can you please provide logs of Community Server and Control Panel for analysis? Logs are located in /var/log/onlyoffice/CommunityServer and /var/log/onlyoffice/ControlPanel respectively.

Additionally, please check if editing of documents works, i.e. just open any document and try to edit it. Let me know the result.

  1. editing document works
  2. result of /var/log/onlyoffice/web.controlpanel.08-16.log , i don’t see /var/log/onlyoffice/ControlPaneland /var/log/onlyoffice/CommunityServer

Please provide all logs from /var/log/onlyoffice/ in the archive. You can upload them to any cloud storage and share an external link.

ok thanks

Onlyoffice log

Thank you for the logs.
It seems that Control Panel cannot access Community Server. Please specify some additional information to get better understanding:

  • whether you changed default port (80) when installed Workspace;
  • if any proxy is used in your environment;
  • if there is localhost in /etc/hosts exists.

Additionally, please execute curl http://localhost and share the output.

Thanks you for your back

That’s strange. Can you please also check if this issue reproduces in any other browser?

i tried with chrome and mozilla, i have the same result

Got it, thank you.
Please execute this command from the terminal of the server where Workspace is installed:

curl http://localhost/api/2.0/portal.json

Also, after that add /api/2.0/portal.json part to the address of your portal and check what it returns in the browser. After that please share both outputs.

result of curl :
Capture d’écran du 2023-08-29 08-25-09

add /api/2.0/portal.json

count: 1,
status: 0,
statusCode: 200,
response: {
tenantId: 1,
tenantAlias: "localhost",
mappedDomain: null,
version: 2,
versionChanged: "0001-01-01T00:00:00",
tenantDomain: "workspace",
hostedRegion: null,
name: "SENUM Office",
language: "fr-FR",
timeZone: {
Id: "UTC",
DisplayName: "UTC",
StandardName: "UTC",
DaylightName: "UTC",
BaseUtcOffset: "00:00:00",
AdjustmentRules: null,
SupportsDaylightSavingTime: false
trustedDomains: [ ],
trustedDomainsType: 1,
ownerId: "2a81fdef-209f-11ee-9d03-067307ac056f",
createdDateTime: "2023-07-12T10:30:48",
lastModified: "2023-07-12T12:18:15Z",
status: 0,
statusChangeDate: "0001-01-01T00:00:00",
partnerId: null,
affiliateId: null,
campaign: null,
paymentId: null,
industry: 0,
spam: true,
calls: true

Thank you. That is getting even stranger.

Since there is one component is not updated, please run a test and update your portal to all actual versions. To update existing ONLYOFFICE Workspace components using DEB packages use command:

bash -u true -it WORKSPACE

I’d recommend preparing whole server backup before running through updating process.

By the way, is it possible to provide us an access to your machine to analyze the issue?

ok i send you access in private message

1 Like

In logs was an error indicating to the usage of IPv6 address for Control Panel:

error: http://localhost/api/2.0/portal.json connect ECONNREFUSED ::1:80

To make it run proreplly we changed localhost to in production.json config of Control Panel located in /var/www/onlyoffice/controlpanel/www/config to avoid usage of IPv6 localhost which is ::1:80 like that:

  "web": {
    "portal": "",

thanks you it’s working now…Happy to learn a new lesson :wink: :smiley: