[confluence] server address incorrect when deploy behind a reverse proxy |version history|external link data|download as

[Report a bug]

some problems that may be related to the internal server address or server address settings when using
confluence onlyoffice connector plugin:

· [conf_server_ip] and [oo_server_ip] are the IP addresses of the confluence server and onlyoffice server (onlyoffice is deployed via docker)
· For end users, confluence and onlyoffice are deployed behind a reverse proxy and are accessed through the two domain names [conf.com] and [oodoc.com] respectively.

Below is the configuration of my Confluence connector plugin

Server settings:
Document Editing Service address: oodoc.com
Confluence Server internal address: conf_server_ip
Document Editing Service internal address: oo_server_ip

After configuring as above, most connector functions work well, but there are still some problems that seem to be related to the server address configuration.

1. “version history”
When I click version history in onlyoffice editor, the browser requests http://[conf_server_ip]/plugins/servlet/onlyoffice/history?xxx , instead of [conf.com]

2. “Download as”
When I click “Download AS" button in confluence attachment page, the browser requests
The return result is:

     "fileUrl": "http://[oo_server_ip]/cache/files/data/",   ###This should be [oodoc.com]
     "percent": 100,
     "fileType": "html",
     "endConvert": true

3. external link data in Spreadsheet
When I tried to update external link data in editor, the browser requested
http://[conf_server_ip]/plugins/servlet/onlyoffice/api?type=reference-data&pageId=110659146, instead of [conf.com]

Where can I change the relevant server address settings?

Document Server version: 7.5.1
Connector version: 4.4.0

4. “Save Copy as”

“Save Copy as” / “Save document as” in ONLYOFFICE editor, the browser requested
instead of [conf.com]

hi @lumos00

We need information about the proxy configuration.
Please clarify the details in this post.


My colleague has already reported the fix for this issue on GitHub.
I will still duplicate the information:

This issue was fixed on the develop branch. Try using this artifact.

1. “version history”

2. “Download as”
still not working.

3. external link data in Spreadsheet
still not working.

**4. “Save Copy as” / “Save document as” **

i’ll try to figure out 2,3 next few days

add mention

Hello, @lumos00

I’ve seen your post. Thank you for your feedback. :handshake:

I’ve relayed the information. I’ll notify you as soon as there’s anything to share regarding the resolution of the issue!

Thanks again and wishing you a Happy New Year and Merry Christmas in advance! :santa:

@Nikolas Happy New Year!

Let’s get back to the topic. :saluting_face:

Is the error the same as you described initially, or has it changed?

If possible, please take screenshots of the browser’s console Network and Console tabs.

To capture these screenshots, please follow the next scenario:

  1. Open the browser’s console (F12 in Chrome/Firefox/Edge).
  2. Perform the actions that lead to the error.
  3. Take screenshots of the Network and Console tabs in the browser’s console.

Changes with fixes for the “download as” issue have been implemented.