ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Confluence ONLYOFFICE integration app shows a blank screen when edit a document

I run into the issue of Confluence ONLYOFFICE integration app plugin.
It shows a blank screen of browser when a user trying to edit any document. The issue happends with some users (not all user have the proplem). The user with the problem has permissons to view a space, edit pages and attachments. The environment the same. The same Chrome browser.
More over, even if my account can successfully open and edit the document by the Olnyoffice plugin and then I switch to a user (by ScriptRunner is a Confluence pluing) who has the problem, then I will see the same blank screen of browser.

How to fix it?

Hello @Aleksandr.K

Please provide some additional information:

  • version of Document Server;
  • version of Confluence;
  • version of the connector plugin.

Does it happen only when you are switching accounts with ScriptRunner? Please run a small test:

  1. Log into your main account and create new post with an attachment;
  2. Try to edit the attachment from your main account - if it works move to the next step;
  3. Open incognito tab and log into your Confluence portal under a user account;
  4. Try to edit the attachment with user account.

Will it make any difference that way?

If possible please record a video demonstration of the issue with ScriptRunner so we can have visual understanding of the issue.

Hi! Thanks for reply!

  • version of Document Server -;
  • version of Confluence - 7.20.3 (DataCenter);
  • version of the connector plugin - 4.1.0

If I edit the attachment with user account in incognito tab I run into the the same problem as I without incognito tab. No difference.
I’ll make a video demonstration later

Please note that you are using an outdated version of Document Server. Please consider updating and checking the situation afterwards.

Hi Constantine!
We updated Document Server to but nothing changed. The issue the same.
How to fix it?

Please provide video demonstration of the issue. Include the process of account switch with plugin to the video too.

Hi Constantine!
How to upload video files?
There are restrictions to upload the files:

“Sorry, that file is too big (maximum size is 4096kb). Why not upload your large file to a cloud sharing service, then paste the link?” It is 11MB. What cloud sharing service do you have to upload the files?
“Sorry, the file you are trying to upload is not authorised (authorised extensions: jpg, jpeg, png, gif, heic, heif, webp).” It is *.wmv file. I can’t upload har/log files of browser either.

You can upload all files to any cloud storage and share a link to it. Which one to use is all up to your liking.

They are uploaded here

Please run another test. There is a higher version 4.2.0 of the connector app is available, please update it and check the situation again.
While checking the situation, please go through next scenarios:

  • switch to to the 1st user account with ScriptRunner app;
  • log in via 1st user account in incognito;
  • disable the ScriptRunner app and check if the behavior changes for 1st user account and also check another user account that hasn’t been used with ScriptRunner yet if possible.

Hi Constantine!
After upgrading Confluence ONLYOFFICE integration app plugin to 4.2.0 the issue had gone. It works even on the older version of Document Server -

I’m glad to hear it.