Conditional formatting formula bug

I’m trying to set some conditional formatting with a formula in which I use decimal values (i.e. 1,3 and 0,05).
In the pop-up menu I input the formula this way :
=G2<>ARRONDI.AU.MULTIPLE(F2*1,3;0,05)

But as soon as I close the pop-up menu with the OK button and reopen the menu the formula as changed to :
=G2<>ARRONDI.AU.MULTIPLE(F2*1;3;0;5)
the commas got changed to semicolons and a zero is missing. The formula is now invalid :confused:

I could make this work by computing the formula in another column and then comparing the value but I would preffer to do everything at once with conditional formatting

1 Like

Hello @DeKaZedd

As I can see the formula spelling is in French. When using File tab > Advanced Settings > Regional Settings > Formula language > French the formula works as expected:
image

If English is used as Formula language instead and formula spelling remains as on your example, then it prompts #NAME? error which is expected. English form of this formula is:

=G2<>MROUND(F2*1,3;0,05)

Please make sure that you are using Formula language in Advanced Settings corresponding to formula spelling.

1 Like

Hello,

Thy but this was not my issue, I really think there’s a bug cause I’ve no problem with LibreOffice (Excel not tested).

I can perfectly use this formula inside a cell but when using it for conditional formatting, the commas are converted to semicolons upon validation, thus rendering the formula invalid.

I tested another formula containing a decimal value and the comma got converted even wierder
formula input for conditional formatting : =S2=(R2*0,5)
formula when reopening the conditional formatting rule : =R2*0=(5)

I can only compute the test in another column and use the boolean result as input for the conditional formating for those formulas to work correctly.

I’m workin on v8.0.1.31

Please provide a video demo or step-by-step scenario on how to reproduce the issue as I seems I am missing something and still unable to reproduce it. That’d be much appreciated.