Compiling on Windows

I am compiling onlyoffice groups for local server using this guide:Compiling ONLYOFFICE Groups for a local server

I wanted to set it up locally first so I used a machine with windows 10.

I decided to use version v12.5.2 and run it, but as I followed the steps, I noticed some files missing from the repository, like the onlyoffice.resources.sql file. It was last seen in v11.0.0, so I got it from there and completed the steps. Once the compilation was over, I am to execute the ManageServices.bat file which is meant to be in the C:\ONLYOFFICE\Services\TeamLabSvc directory. But it is not visible there. So I copied the file in the /build directory into the file and ran it. After completing the remaining steps for IIS and set it to port 8080, the “Error 500. Internal server error” is being displayed.

I am not sure where I went wrong, any advice?

hi @BimsaraM
We don’t recommend performing this on Windows 10.
Please check the logs, or provide them here :saluting_face:
Are there any errors in the event viewer?

Hi, here are the logs for the BuildandDeploy.bat and ManageServices.bat files.
The event viewer also came with no warnings or errors.

BuildandDeploy.docx (165.8 KB)
ManageServices.docx (1.7 KB)

hi @BimsaraM

Could you please add a screenshot of the error?

Check if the <customErrors mode=“On” option is enabled in the

C:\Program Files (x86)\Ascensio System SIA\CommunityServer\WebStudio\Web.config file. If not, enable it, try to restart the site in IIS, and provide a screenshot of your error.

Hi, I re ran the program with the changes. This is what is displayed.

Hello @BimsaraM

Provide logs after accessing the portal via browser. Logs are located in C:\Program Files (x86)\Ascensio System SIA\CommunityServer\Log\.

Hi @Constantine, I could not find this directory that you have specified. Are you referring to the build.log or deploy.log files in the cloned directory? If so they are here:
Build.log.docx (3.7 MB)
Deploy.log.docx (2.3 MB)

Sorry for the late response. Please provide the following:

  • web.connections.config config from C:\Program Files (x86)\Ascensio System SIA\CommunityServer\WebStudio;
  • logs from the site directory to which you copied deploy\OPENSOURCE.SERVER\ after compilation.

Hi, I these are the contents of the web.connections.config file :slight_smile:

<?xml version="1.0" encoding="utf-8"?>
  <clear />
  <add name="default" connectionString="Server=;Database=onlyoffice;User ID=root;Password=;Pooling=True;Character Set=utf8;AutoEnlist=false;SSL Mode=none;AllowPublicKeyRetrieval=true;Connection Timeout=30;Maximum Pool Size=300;" providerName="MySql.Data.MySqlClient" />

I also noted this error in the log file deploy.log in the /build directory.

     1>Done Building Project "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\build\msbuild\deploy.proj" (DeployWeb target(s)).
     1>Done Building Project "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\build\msbuild\deploy.proj" (InvokeInParallelWithinThisProject target(s)).
     1>Done Building Project "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\build\msbuild\deploy.proj" (default targets) -- FAILED.


       "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\build\msbuild\deploy.proj" (default target) (1) ->
       "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\build\msbuild\deploy.proj" (InvokeInParallelWithinThisProject target) (1:3) ->
       "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\build\msbuild\deploy.proj" (DeployService target) (1:5) ->
       "C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\module\ASC.WebDav.Svc\ASC.WebDav.Svc.csproj" (PrepareResourceNames;ResolveAssemblyReferences;CopyFilesToOutputDirectory target) (32) ->
       (CopyFilesToOutputDirectory target) -> 
         C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(4502,5): error MSB3030: Could not copy the file "obj\Debug\ASC.WebDav.Svc.dll" because it was not found. [C:\Users\hSenid\Documents\Compilations\24th_jan\OnlyOfficeCommunityServer\module\ASC.WebDav.Svc\ASC.WebDav.Svc.csproj]

    0 Warning(s)
    1 Error(s)

I found this in the event viewer :

Log Name:      Application
Source:        ASP.NET 4.0.30319.0
Date:          1/24/2024 3:01:34 PM
Event ID:      1309
Task Category: Web Event
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      HMS-LP-196
Event code: 3005 
Event message: An unhandled exception has occurred. 
Event time: 1/24/2024 3:01:34 PM 
Event time (UTC): 1/24/2024 9:31:34 AM 
Event ID: b6ada5580a78462292dddc5699649ba3 
Event sequence: 4 
Event occurrence: 1 
Event detail code: 0 
Application information: 
    Application domain: /LM/W3SVC/2/ROOT-1-133505622673616689 
    Trust level: Full 
    Application Virtual Path: / 
    Application Path: C:\Compilations\24th_jan\WebStudio\ 
    Machine name: HMS-LP-196 
Process information: 
    Process ID: 7928 
    Process name: w3wp.exe 
Exception information: 
    Exception type: MySqlException 
    Exception message: Access denied for user 'root'@'localhost' (using password: NO)
   at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
   at MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.ReadPacket()

Request information: 
    Request URL: http://localhost/ 
    Request path: / 
    User host address: ::1 
    Is authenticated: False 
    Authentication Type:  
    Thread account name: IIS APPPOOL\COMMUNITYSERVER 
Thread information: 
    Thread ID: 6 
    Thread account name: IIS APPPOOL\COMMUNITYSERVER 
    Is impersonating: False 
    Stack trace:    at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
   at MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.ReadPacket()
Custom event details: 

Event Xml:
<Event xmlns="">
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="32768">1309</EventID>
    <TimeCreated SystemTime="2024-01-24T09:31:34.7306938Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security />
    <Data>An unhandled exception has occurred.</Data>
    <Data>1/24/2024 3:01:34 PM</Data>
    <Data>1/24/2024 9:31:34 AM</Data>
    <Data>Access denied for user 'root'@'localhost' (using password: NO)
   at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
   at MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.ReadPacket()

    <Data>   at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
   at MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.ReadPacket()

Did you create data base without password? As I can see, in web.connections.config the password field is blank:

Hi @Constantine , I removed the password from the mysql server and it worked.

A few issues - the activation mail is not working.
Also I cannot edit the documents using the editors.
The control panel is also not visible.

I’m glad to know that it worked.

Please provide screenshot of Settings > Integration > SMTP Settings page when clicking on Save button.

Does it return any error when trying to open a document? Also, please make screenshot of Settings > Integration > Document Service page too when saving the settings.

Do you mean in the list of all modules?

Hi @Constantine, Here are the screenshots you requested:

Settings > Integration > SMTP Settings

Settings > Integration > Document Service

And by ‘control panel’ what I meant was the Control Panel module available when running onlyoffice workspace with docker. (where we can control rebranding, sso etc).

As I can default settings are used. Can you elaborate on what exactly is not working? Do you receive a message or not?
Additionally, please check if database credentials are correct in ...\Services\TeamlabSvc\TeamlabSvc.exe.config.

As for the missing modules: I have to inform you that compiling Community Server does not include compiling of Control Panel and Document Server.

You can compile Document Server separately with this guide:

Then connect it to your Community Server with one of these guides depending on machine OS:

But, unfortunately, we do not have guides on how to compile Control Panel. With that said, I’d recommend installing Workspace instead if you need all functionality of it:

Hi @Constantine , thanks a lot for the document server integration info. Regarding the mail server, I need to activate the email account. But the activation mail is not delivered. I re-checked the credentials as well, but all is fine. This is what the screen looks like on the mail module:

And regarding keycloak, is there any other way we can manually configure it for windows compilation? (without considering the other options that use docker?)

Did you try sending a test mail in SMTP settings?

I’m not quite following. Do you want to configure SSO?

Hi @Constantine , I have compiled the document server on an ubuntu machine as given in the instructions guide, and I am able to start the FileConverter and DocService but I am not sure on how to connect to the community server. I suppose it has something to do with the document server settings in the settings page.
Can you give me the directions on how these can be connected? Or the proper way if this method is incorrect?

Also regarding the mail server, I set it up using docker on a linux server. I modified the A-record of the domain I was using as well and tested it. I used the command: bash -ics false -ids false -icp false -ims true -md -es true. But that too came up with a connection faults while trying to connect. Here are the current setting I have applied and the error message that I am getting:

Any advice on this?

I have mentioned the guides on how to connect Document Server to Community Server earlier:

You might want to test out functionality of Document Server before connecting to Community Server to make sure that everything works.

I’d kindly ask you to create a separate thread for that as it is related to the configuration rather than compiling, just to avoid mixing up different topics in one thread per say.
Please make sure to mention that all components are manually compiled.

1 Like