Community document Server

I have installed Nextcloud on Ubuntu and installed the OnlyOffice application on it, along with the Community Document Server. Now, the issue is that locally we can access and work with Excel and Word, but when we try to open them after accessing Nextcloud through the internet, an error occurs, and OnlyOffice doesn’t work. Please help me resolve this issue

hi @ahmad :wave:

  • Is the document server accessible from the internet
  1. Type of installation of Document Server (exe, docker, deb/rpm).
  2. How you performed installation, send me also the link to the guide you used.( Have there been any changes to the instructions?)
  3. How did you install NextCloud?
  4. Provide a screenshot of the error.
  5. Version of Nextcloud + Version connector ONLYOFFICE
  6. Version of ONLYOFFICE Docs.

i have installed Nextcloud on Ubuntu and added the Community Document Server to it. After that, installed OnlyOffice. When accessing Nextcloud within your local network, files open successfully using the Document Server. However, when try to access Nextcloud from the internet, you encounter an error stating "document loading failed.i have also attached a screenshot. my

current Nextcloud version is 27.1.3.

Firstly, you need our official connector.


If you want documents to be opened not only within the local network, you need to specify the address of the document server accessible from the internet.

Installing ONLYOFFICE Docs

You will need an instance of ONLYOFFICE Docs (Document Server) that is resolvable and connectable both from Nextcloud and any end clients. If that is not the case, use the official ONLYOFFICE Docs documentation page. ONLYOFFICE Docs must also be able to POST to Nextcloud directly.

I have installed the OnlyOffice server. Now, when I try to connect it with Nextcloud, I am encountering this error.

the scenario is that I have configured the local OnlyOffice server at, and I have entered the corresponding secret key from local.json. However, it is not accepting it and is giving an error.

Furthermore, I have added the following details in the configuration file of Nextcloud:
‘onlyoffice’ =>
array (
“jwt_secret” => “mz8n3ntB3sTd15XgTQcHJaHE5S2LGa90”,
“jwt_header” => “AuthorizationJwt”

  • Please attach a screenshot of the “Advanced Server Settings” page (feel free to send it in a private message)

  • also provide the local.json file for a more thorough analysis.

There is no need for this.