Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Changing the default language of the Document Server interface?

Hi!

We’ve installed Document Server and connected it to Nextcloud. This is working fine.
I’m now trying to change the default language of the Document Server interface to Dutch.
I’ve found this article and edited …/web-apps/apps/api/documents/api.js with the following changes:

editorConfig: {
“…”
}
},
lang: ‘nl’,
mode: ‘view or edit’,
location: ‘nl-NL’,

and

DocsAPI.DocEditor.defaultConfig = {
    type: 'desktop',
    width: '100%',
    height: '100%',
    editorConfig: {
        lang: 'nl',
        canCoAuthoring: true,
        customization: {
            about: true,
            feedback: false
        }
    }
};

Unfortunately, after saving the changes and running supervisorctl restart all, documents still open in English.

I’m probably missing something obvious but I can’t seem to figure it out.
Could someone please point me in the right direction? Thanks in advance!

Hello,

Please revert any changes added to api.js and do not change this file in the future. In Nextcloud+ONLYOFFICE integration, the editor interface language is set according to the language set in the user’s profile in Nextcloud. Please make sure you set Dutch language in the profile. If you have already done so and the editor language is still English, please specify:

  1. Version of Nextcloud.
  2. Version of ONLYOFFICE connector app (you can find it in the app list in Nextcloud).
  3. Version of Document Server (you can find it by clicking the About button on the left toolbar of the document editor).

Hi Carl,

Thanks for your response. I’ve reverted the changes in the api.js file.
The Nextcloud user’s profile is in Dutch, just as the region settings. These are forced thru Nextcloud config.php.

Nextcloud version: 23.0.5 and 24.0.1 (separate instances)
Connector app: 7.3.4
Documentserver: 7.1.1-23 (same results on 2 separate installations)

For installation I’ve followed this guide.

Hello @vincent,
Could you please describe in more details how you force the language settings in config.php?
I couldn’t reproduce the issue on Nextcloud 24 with connector 7.3.4 and DS 7.1.1:
image

Hi Carl,

In …/nextcloud/config/config.php you can put
‘force_language’ => ‘nl’,
‘force_locale’ => ‘nl_NL’,

I just took these lines out and set the language manually, but OnlyOffice still shows up in English. :frowning:

Edit: To further clarify, my latest endeavor is a clean installed Ubuntu 22.04 VM, the other runs Ubuntu 20.04. Nextcloud runs on Ubuntu 20.04 as well.
The OS language is English for all.

I tried connecting one of the other Nextclouds we manage that never had the community document server app installed to rule out any possible interference, but there it also shows up in English.
The actual document and text language is, in fact, Dutch, just not the interface itself.

To test some more I’ve switched my personal Nextcloud back to the “community document server” app, because previously that was definitely in Dutch. Now however, that also shows up in English.

Plot twist: when I change the Nextcloud language to German, the ONLYOFFICE interface does show up in German.
EDIT: Apparently ONLYOFFICE honors all languages EXCEPT Dutch for us.

Hi Carl,

I just noticed there’s a new version of the connector app released; although both the settings page and the ‘plus icon’ context menu (for “new document”/ “new spreadsheet” etc) are still in English, the editors now correctly show in Dutch.

Hello Vincent,
I’m glad the issue is resolved (at least the interface part). As for missing translations of connector settings and file creation menu, we are looking into the issue. I will inform you here.

Thanks for the effort!

Hello Vincent,

I’m afraid we haven’t added NL translations of these items yet. You can find the list of available translations here:

Ah, it’s okay, that’s not a bug then :slight_smile:
I’m in the translation program myself, I’ll see if I can get some more work done there!