Can't open docx documents

I don’t know why but there are many *.docx documents that I can’t open now. These documents were created with Onlyoffice and previously opened normally. Now, when trying to open, error messages appear, depending on where you try to open the document from:

If I access from Onlyoffice / recent folders, a window appears

“cannot be opened or doesn’t exist”

and if I access from Windows Explorer, appears another one window

“File format is not supported”

It does not happen with all the documents, but it does with quite a few

I will appreciate comments.

OS version: Windows 10 Pro
App version: ONLYOFFICE Desktop Editors version (x64 msi)
Downloaded from: ONLYOFFICE website

Hello @Barth

Is it possible to share problematic file with us?
Also, have you tried re-installing Desktop Editors? If not, please try this:

  • Remove contents of this folder from your PC: C:\Users\User\AppData\Local\ONLYOFFICE\DesktopEditors\data\cache
  • After that please re-install Desktop Editors and re-check the situation.

Hello Constantine, I have removed the cache folder and reinstalled Onlyoffice. So I tried to open some of the files but it still doesn’t recognize it.
“cannot be opened or doesn’t exist”
So I would like, as you said, to send you one of the many docx that I cannot open. But I don’t know how to send it to you.
Thanks and regards.

Hello @Barth

You can upload it to any cloud storage and send me an external link (do it via PM if the document has any sensitive data).

Ok! :+1:
The link is

I’m not sure I did it right

Indeed, the file cannot be opened.
Can you provide any details in particular about the file? For now it seems like it is not a OOXML document even though it is DOCX since I cannot even check its XML data. After what kind of action you wasn’t able to open it, can you recall?

I think I can’t remember actions with this file. I have a folder where there are many files created with Onlyoffice, and some can be opened and others cannot.
What I think I remember is that I did not write in these documents but copied the text from another processor, although I did the same for the docx documents in the same folder that can be opened.
They are song lyrics that were in another word processor, and I changed them to Onlyoffice.

I have realized one thing.
These files are in a folder, like I said.
In that folder are the same document files, apart from docx, in the format of the other word processor, from which I copied the text for Onlyoffice.

Now I realize that if a docx file doesn’t open with Onlyoffice, its equivalent in the other processor’s format won’t open either.
And the docx that does open with Onlyoffice, its equivalent in the format of the other word processor is also opened.

Indeed, the file that you’ve shared cannot be opened in MS Word too.

Can you elaborate on this? What kind of formats are also there and to which editor in particular you are referring?

Yes, they are tdmx files, from TextMaker (another word processor), as i like onlyoffice more, i was copying documents from TextMaker to Onlyoffice, but I didn’t convert them, instead I opened the tdmx file in TextMaker, selected all the text, CTRL+C and then in a new Onlyoffice document I pasted with CTRL+V and I saved the new docx file.

I did the same with other documents, and those other documents have no problem opening with Onlyoffice. Total that some open and others do not open. And it’s the same process and the same file type. I seem to remember that the documents that I can’t open with Onlyoffice I could open them a while ago.

Thanks for your interest

According to the the provided description, it really looks like these files were corrupted outside the both editors.

Could you please try to reproduce the issue with brand new documents so we can analyze it?

Just to clarify: do I understand it correctly that both files, e.g. the TDMX file from which text was copied and DOCX into which the text was pasted, cannot be opened in both editors? Like, TDMX file in its TextMaker and DOCX in Desktop Editors.

it really looks like these files were corrupted outside the both editors.

Yes, as I’ve been explaining what’s going on, I’ve also come to the conclusion that these files are corrupted.

Could you please try to reproduce the issue with brand new documents…

I have tried it again, I have gone to the problematic folder and I have opened a tmdx document (one of the ones I have been able to open), I have selected everything, CTRL+C and I have created a new document in Onlyoffice, then CTRL+V and I have saved the new docx document. It opens fine and no problem.

the TDMX file from which text was copied and DOCX into which the text was pasted, cannot be opened in both editors? Like, TDMX file in its TextMaker and DOCX in Desktop Editors.

Yes, you understand correctly, if a docx can’t be opened with onlyoffice, the equivalent in tmdx can’t be opened with Textmaker either.

For example: if the document LYRICS.docx cannot be opened, then LYRICS.tmdx cannot be opened either, and the same for the documents that can be opened.

Hi again, I know what’s going on.

I have a music program that occasionally crashes, and if Onlyoffice is open when it crashes, any documents that are currently open are then unusable. I checked it last night.

So now I know what it is. I’ll try not to have documents open in Onlyoffice when I have this music program open

I really appreciate your attention, Constantine. :slightly_smiling_face: :+1:

Hello @Barth

Wow, that’s unexpected. So it also crashes the TextMaker? Can you name the program so we can analyze what’s going on out there?

Well, I can tell you the name of the program, Reaper, but I’m not sure what it has to do with the crash, it’s the music software I use most frequently now, and it doesn’t happen in other music programs, but sometimes the crash has occurred without Reaper being open.

When this happens, the screen goes black for a few seconds and the program does not work, after those seconds the program works again, with the difference that after the blockage, the night light that I have normally activated in W10 is deactivated, and it turns off. notice a higher brightness.

I don’t know if it blocks the TextMaker because I don’t use it now. Now I only use Onlyoffice, and it’s the only program I usually have open when I use Reaper.

Hello @Barth

That is really weird behavior. Does it happen when Desktop Editors are open in particular or just randomly with any other program too?

Yes, it’s a strange issue that has nothing to do with Desktop Editors, the problem already existed before installing Desktop Editors.

It happens mainly when I have Reaper open, but I hardly use any other software.

Although sometimes I use other music software but it never happens with this other software.
Sometimes black screen ended in BSOD.

But I don’t want to bother you with this problem. It is something difficult to solve. Thanks.

Maybe you should also check PC components, e.g. RAM or HDD.
Anyway, I hope you will find a solution to this issue.

Yes, from the moment I checked that the crash made useless the docx that was open at that time, the issue has nothing to do with desktop editors
In any case, I really appreciate your help and the time spent :clap:

Desktop Editors support has been great. :+1:
Thanks again.

1 Like

Hello Constantine and Barth!
I am sorry for interference.
I have exactly the same problem: I am not able to open the file .docx that I edited yesterday. The file is a document file and it was created on my computer in OnlyOffice. Today I got message Format Is Not Supported. I followed suggested steps and re-installed OnlyOffice. The problem still exists.
Windows 11
ONLYOFFICE Desktop Editors version (x64 exe)
Downloaded from