Can not connect to mysql server after udate docker image

Hi there,

I tried to recreate container using latest image, but it stuck on starting screen.

i checked logs, it repeating:

+ mysqladmin --defaults-extra-file=/etc/mysql/conf.d/client.cnf ping
�mysqladmin: connect to server at 'onlyoffice-mysql-server' failed
error: 'Can't connect to MySQL server on 'onlyoffice-mysql-server:3306' (113)'
Check that mysqld is running on onlyoffice-mysql-server and that the port is 3306.
You can check this by doing 'telnet onlyoffice-mysql-server 3306'
+ sleep 1

But i checked mysql container, it is working fine.

2024-03-03T11:42:09.253988Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.29) starting as process 1
2024-03-03T11:42:09.265655Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2024-03-03T11:42:09.465660Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2024-03-03T11:42:09.737443Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2024-03-03T11:42:09.737469Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2024-03-03T11:42:09.742651Z 0 [Warning] [MY-011810] [Server] Insecure configuration for --pid-file: Location '/var/run/mysqld' in the path is accessible to all OS users. Consider choosing a different directory.
2024-03-03T11:42:09.760524Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '::' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2024-03-03T11:42:09.760643Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.29'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  MySQL Community Server - GPL.

thank you for your help
Dong Daming

Hello @dongdaming
Please clarify your exact steps before the issue arose. Did you try to update Workspace portal?
Additionally, please go to the host and run docker ps command, and show the output result.
Also please share the entire Community server logs folder, it’s located here: /app/onlyoffice/CommunityServer/logs/

thank u for your reply.
docker ps result

b8b97f72d589   onlyoffice/communityserver:latest     "/app/run-community-…"    8 days ago       Up 2 minutes
        3306/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp, 9888/tcp,>5222/tcp, :::5222->5222/tcp,>80/tcp, :::8100->80/tcp,>443/tcp, :::8101->443/tcp   onlyoffice-community-server
5fd7c1443705   onlyoffice/documentserver             "/app/ds/run-documen…"    2 months ago     Up 10 hours
        443/tcp,>80/tcp, :::8102->80/tcp
f4192572a7f3   onlyoffice/controlpanel               "/var/www/onlyoffice…"    2 months ago     Up 10 hours
        80/tcp, 443/tcp
13a87ad28005   mysql:8.0.29                          "docker-entrypoint.s…"    2 months ago     Up 12 minutes
        3306/tcp, 33060/tcp

there many logs in /app/onlyoffice/CommunityServer/logs/, which one i should share

Hello @dongdaming
I don’t see ElasticSearch container in your docker ps output result. How exactly did you install Workspace? Please point me to the guide.

I tried to recreate container using latest image, but it stuck on starting screen.

Please let us know your exact steps on this action. Have you tried to update entire installation?

As for the logs, the entire folder would be more helpful. You can contact me directly via PM, if you don’t want to place logs in this thread.
One more thing, please go to your portal domain name address in a browser and make a screenshot of the issue there.