Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

CalDAV export error

I’ve installed OnlyOffice 12.0.0.1726 Community Server in a virtual machine, which I access via the IP address not domain name.

I get the error below along with a Bad Gateway flashed message

Screenshot from 2022-06-10 15-25-30

Is there something that MUST be configured to ensure CalDAV works, that I haven’t ?

Hello,

CalDAV should work without any configurations. Please specify the OS of the server and type of installation of Community Server (docker, deb/rpm, exe).

Hello @Carl !

I think there is a lock file from a previous run from radicale service.
Сheck that the service is not running, and if so, delete the lock file.

if you don’t have something like this:

ps ax | grep radicale
  43761 ?        S     16:01 /usr/bin/python3 -m radicale --config /var/www/onlyoffice/Services/TeamLabSvc/radicale.config

remove the lock file:

rm /app/onlyoffice/CommunityServer/data/radicale/collections/.Radicale.lock

and then you need to start onlyofficeRadicale service (inside onlyoffice-community-server docker or local service)

Hello @Carl I’m running Debian 11 headless, from the deb install, there was a script on OnlyOffice to complete the install which I used. It’s the community version, not using docker for anything.

It’s running in a Proxmox virtual machine.

During the install I didn’t notice any errors.

Hello @wwwfyl I ran that command with the following result

administrator@onlyofficeserver:~$ ps ax | grep radicale
59417 pts/0 S+ 0:00 grep radicale

It doesn’t look like there is a lock file.

@neogrid

Fine!

Just remove the lock file and start the service:

service onlyofficeRadicale start

Hello @neogrid,
Could you please reproduce the issue and send me the log file radicale.log from /var/log/onlyoffice/ ? You can send it via PM.

Hi @Carl I’ve got a strange problem with my Debian build, it doesn’t recognise my DNS server, hence the Bad Gateway message in onlyoffice. I think my problem is related to this. I’m doing a rebuild using the script, now I know the CalDav link should work, I’ll post back the result here.

I’ve built many vm’s using Debian and never had this issue.

I’ll post back here my result.

Hi @neogrid,
I received your logs but there is no radicale.log file there. Could you please check if the Radicale service is running?
systemctl status onlyofficeRadicale

Hi @Carl

yes that was it, the service wasn’t started. The link was working once started.

What is the command to automatically start the service ?

I thought it should be
sudo systemctl enable onlyofficeradicale

Once i rebooted the system the service had not started.

Not a big deal, however, thanks very much for for you help.

Hi, do you mean that the service does not start automatically after a reboot even when you run systemctl enable onlyofficeRadicale?

Yes exactly, I ran the enable command, checked the status, rebooted, checked the status and it wasn’t running.

Not a big deal, but if you can reproduce it, then something to look into.

Otherwise it could be my build, but it’s a basic headless debian 11 running just onlyoffice.