Need dedicated support? Click here
Need dedicated support?
Click here

Bug - sometimes, the spellchecker is lost in translation

My document is mainly in french, but mixes french and english contents (even in the same text zone).
Let’s say I have a rectangle with text in french inside.
I add some text in english. Everything in english is underlined by the spell checker.
I select the english part, and select “english” as the language.
Often, most of the text is no longer underlined except for a word which is still considered as badly spelled.

The weirdest is that if I right-click the word, the spell checker propose me the word with the same spelling.
If I close the doc and reopen it, the problem is no longer here… so no point sending you my file…
This bug happens quite often… but is quite hard to reproduce :frowning:

And it’s the same the other way around.
Just replaced a text in english by another text in french.
After I choose “French” as the language, rugby is still underlined and the spellchecker offers to replace it by … rugby written the same.

Hello @arcqus

Could you please reproduce the issue and provide us with a video file?
With language switching display (ENG/FRA)

Hi @Nikolas
This issue is a bit random, so, I’ll try.
First, with a file that is currently opened on my computer, you can see that while “construction” is spelled correctly in french and that the language is set to “french”, the spell checker underlines it and offers as a correction… the same spelling:
I tried in a new file, here is what I got:
Note the weird behaviour: when I write in english in the french zone, only the last word is underlined (games) whereas I, like, building should be underlined too as these are not french words.
This file is here:

But as said above, when the file is closed and reopened, the issue is no longer there.

As it’s a bit random, I guess that’s all I can do.

Thank you very much for the file and video record, @arcqus
We are checking the situation. I will let you know when I get something.

Hi @arcqus

Please specify if you switched between ENG/FRA languages when entering this text?

You can see the moment when I switch btw FR/EN. Otherwise, no switch.

Hey @arcqus

Please accept my apologies for the delay in responses.

We have an enhancement suggestion Automatic text language detection.

We are working on it already (internal tracknumber - 45194).
I’ve added your request to mentioned suggestion.

At the moment, to avoid spelling problems, we can advise switching the OS layout when entering sentences in different languages.

That is, enter the text in French on the French layout, and enter the text in English on the English layout.

The French dictionary includes common English words in French. In Word, verification is also carried out if the French language is set for the entire text.

I may have missed some of the problems described.
Please don’t hesitate asking questions if you have any.

Hi Nikolas
Thanks for your answer.
This is clearly not a blocker, and I’ll wait for the automatic text language detection to be delivered.
Regarding your proposition to change the OS layout, this is clearly not an option for me :slight_smile: as in the same file I mix french and english.

1 Like