Broken PDF after editing

Do you want to: Report a bug
OS version: Windows 11
App version: 8.1.0.169 (x64 exe)
Downloaded from: ONLYOFFICE website

Hi,
Firstly, I want to say that I really appreciate that You added powerful features to PDF, but honestly right now it’s very easy to break it.

Here is example with table created in OnlyOffice Document:

The same file with other PDF editor in this case Ashampoo PDF 3 Pro:

Here are files from video:
PDF File (25.3 KB)
DOCX File (25.3 KB)

Hello @dedoci
Thank you for the provided data! We are looking into it.

Hello @dedoci
Thank you for valuable data! We have found a bug and we have started working on it. I will update this thread once release a fix for this situation.

Hello @Alexandre,
If You want I can send You more examples of broken PDFs - maybe I just have a bad lack with this new PDF Editor, but I tried it on around 5-7 files and only one worked well.

Hello @dedoci
Sure, go ahead.

But do You want to create new topic for every issue, or just post it here?

Just post them here with description on the usage scenario. We will check if there’s the same bug or something else.

Link to file

Link to file

File PDF (282.0 KB)

File (242.5 KB)

@dedoci thank you!
We will check them out. I will update this thread once we have something to share.

This one (sample.pdf) has been checked. A separate bug has been found. Thank you!

This file’s missing background color after clicking the ‘Edit text’ button is a bug. We have started working on it. Thank you!

All other files have also been checked and we have started working on the detected bugs. @dedoci thank you for the valuable data!

I found another example today:

Files:
Docx_file (26.1 KB)

PDF_File (30.9 KB)

Hello @dedoci

Thank you for another report. We are checking this one, I will keep you posted about the results.

We have registered a bug on this behavior. Thank you very much for your interest and for reporting this issue.