ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Automatically Update to Latest Version?

Most software these days tells you when there is a new version (major or minor) and asks if you want to update. This doesn’t appear to be so for OnlyOffice (Desktop Editors), at least, not on Linux Mint.

Or am I missing something?

I just discovered this week that I had missed the last few updates. I was still using 7.0, and the latest version is 7.2.

Is there a way to be notified about new versions?

Hello @Glsonn

In the Settings of Desktop Editors you can set the ‘Check for updates automatically’ to every day or every week to receive notifications when new version is available without need to do it manually:

I don’t see that option in Settings. All I see there is User name, Interface language, scaling, and theme, and Open file.

Am I looking in the wrong place?

Anyone else able to see this? Or anyone else have this problem?

@Constantine , this is what my Settings screen looks like.

@Constantine any more info here?

Sorry for being absent for a while.

Could you check the version that you are currently running?
Also, I’d like to know where did you download the app? Additionally, please confirm that you are using Linux Mint and provide please OS version too.

I have OnlyOffice (flatpak).
I’m running Linux Mint 20.3 Cinnamon on an old Macbook Pro.
I downloaded OO here: ONLYOFFICE desktop and mobile apps | ONLYOFFICE


Unfortunately, on the flatpak installations the ‘Check for updates automatically’ feature is not available because the updates are managed by flatpak updater service. By default, it scans for updates automatically 10 minutes after every system boot. Also, updating the flatpak apps can be done manually with command flatpak update.

Thanks for the info. Are you saying that the flatpak version will essentially do the same thing as checking that box on a non-flatpak version and that I should be automatically made aware of OO updates in the future?

It works a bit differently. Flatpak automatically looks for the updates when you log into the system. This behavior could be turned off so you didn’t receive updates automatically. So try checking it in next settings of your OS:
Go to Update Manager > Edit > Preferences > Automation > look for Other Updates and turn on Automatically update flatpaks.

Thanks for the explanation.

When I was at version 7.0, I wasn’t using the flatpak version, so this wouldn’t have applied. Back then, I must not have had the first toggle you mentioned turned on. I will make sure the flatpak toggle is on.