ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Apt-get upgrade onlyoffice-communityserver dependency fail

My community server rev is old.

But when I run apt-get upgrade onlyoffice-communityserver I get a dependency exception.

 apt-get upgrade onlyoffice-communityserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 onlyoffice-communityserver : Depends: elasticsearch (= 7.16.3) but 7.17.10 is to be installed
                              Depends: dotnet-sdk-7.0 but it is not going to be installed

My packages look like

ii dotnet-apphost-pack-6.0 6.0.16-1
ii dotnet-host 7.0.5-1
ii dotnet-hostfxr-6.0 6.0.16-1
ii dotnet-runtime-6.0 6.0.16-1
ii dotnet-runtime-deps-6.0 6.0.16-1
ii dotnet-sdk-6.0 6.0.408-1
ii dotnet-targeting-pack-6.0 6.0.16-1
ii elasticsearch 7.10.0
ii onlyoffice-communityserver
ii onlyoffice-controlpanel
ii onlyoffice-documentserver 7.3.3-49~stretch
ii onlyoffice-xmppserver

Any suggestions on a fix? On Ubuntu 20

Hi @ivan

Please note that we recommend to make backup of the data (or snapshot) before performing any actions on the server.

Take a look at this instruction before performing the update

  1. Download the following script via terminal:

  2. After that please update your components of ONLYOFFICE by execution following command:
    sudo bash -u true -it WORKSPACE

Thanks Nikolas
I’ll try this weekend after a backup of the OO VM :wink:

Hi Nikolas…

The upgrade process went “OK”, I saw no issues BUT 3.

[1] ALL the ports I use were LOST. I use 6443 for SSL into portal and 5433 into DOC server. These were replaced by 8083 8082 etc. is there a way to preserve the existing ports in use?
(nginx conf ???)

[2] I have a commercial wild card CERT onlyoffice.key and onlyoffice.crt IN THE RIGHT place but the upgrade did not find these or apply them

[3] My configuration for doc server and mail server were all lost

The database seemed OK.

I backed out to a backup.

Any ideas what causes 1,2,3??


How accurate is this for current release of community server.portal.doc server running in bare metal Configuring OnlyOffice Docs with non-standard port - Aurora Corporate documentation

hello, Ivan

it was necessary to start with this part :slight_smile:

You used a third-party instruction to install ONLYOFFICE (Configuring Only Office Docs with non-standard port)

Usually we recommend to change ports via installation script or docker flags: Installing server version with additional script parameters - ONLYOFFICE
This way you will keep your custom ports during the update steps. As for guide which you followed, we didn’t test it, so we cannot provide any guarantees of stable work.

our installation script

Change the installation script for yourself
after updating try to re-set the port values that you changed according to the instructions you provided.

I have resolved this! Thanks.

We are glad that the problem was solved :+1:

1 Like