7.4 Upgrade breaks Nextcloud Integration (Private IP Address)

Since updating our document server to 7.4 we can no longer view documents in Nextcloud. The document server runs in a 20.04 container, installed using packages and running behind nginx. When trying to view a document the OnlyOffice frame loads, but then fails reporting download failed. There is nothing in the err.log, but in out.log for the convertor I see

Error: DNS lookup, host:) is not allowed. Because, It is private IP address.

It’s not clear to me which config is actually in operation, default or production-linux (How do you choose?) but I have tried to add:

 "request-filtering-agent" : {
    "allowPrivateIPAddress": true,
    "allowMetaIPAddress": false

to both configurations as described here:
With no luck.

Has something changed with 7.4?

This problem has gone away. I don’t know why.

Hello @Zotan

I’m glad that everything works now.
If you face this issue again please feel free to contact us back in this thread!