ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

2fa issue

Hello,

I did enable 2fa long time ago and then disabled it. I was loging only with e-mail/password nicely.

In the menatime, I did change my e-mail address, but everything was still working fine.

Now that I reenabled the 2fa, the authenticator app codes doesn’t work anymore and I am unable to login with my main account.

Is there anyway to reset the 2fa, so I can setup it again from scratch?

I managed to get in with another account and managed to disable the 2fa completelly. The real issue is that I am unable to reenable it an log with my main account.

Any ideas? Thanks in advance.

Regards,
Bruno Leon

PS. I am self-hosting on docker, ubuntu server 22.04, every module is up to date.

Hello @brunoleonadvogado ,

I will contact you in private messages.

@Russell, your solution works great in order to disable the 2fa from the login. However my problem is that if I reenable it, I do not get QR code to reset the process.

In short, I am obliged to get stuck with the e-mail/password login only. Is there anyway to reset the 2fa an get a new QR code for my main login?

Hello @brunoleonadvogado,

Sorry for the late reply.

Do you have access to the portal from an administrator account? Since the administrator can reset 2fa for each user in their profile, or disable 2fa completely so that everyone can enter and reset their 2fa application themselves

if I misunderstood something in this scenario, please provide details/step by step

@Russell, the issue is the following:

1. If I disable 2fa, like so:

Then every user can access the portal using their login/password;

2. But if I enable it from the same screen, like so:

Then when the users try to login, the portal requests straight the 2fa from the app, I mean, it DOES NOT give us a new QR code, so if the user doesn’t have the old 2fa anymore, this method cannot be used, see below:

In short, it seems that the portal is keeping the old 2fa, even if we disable and the reenable it again, that is why I am trying to completely RESET IT, and make another 2fa from scratch, you see?

Hello @brunoleonadvogado ,

In this case, you can enter the portal through the administrator account, enable the 2fa function in the portal settings, enter into the user account and reset the 2fa settings for him in his profile


Ok @Russell, thank you very much. It is all working now.

Regards.

You are welcome! Contact us if you will have any other questions.