Unable to login after restoring the backup with 2FA enabled

I’ve just tried to restore the previous backup of onlyoffice, which has 2FA enabled. We are unable to login the restored version anymore. Tried the “Forgot password” function with no luck, it will ask for the Google Authenticator code, but the GA code does not work anymore. We’ve also lost the backup code.

Anything we could do to get back to our onlyoffice?

Thanks in advance. :pray:

:pensive:
Hi @km.hy

Are you using (Cloud solution) SaaS or ONLYOFFICE Workspace?
I see the tag, but anything is possible.

I use docker to setup the onlyoffice community edition

Can you tell a little more about the situation that occurred?
We’ll try to help you.

Please specify the following information:
(Complete or specify your sequence of actions)

  1. On your portal, you have enabled 2FA.
  2. You have backed it up.
  3. Have you lost the Google Authenticator app?
  4. ?

My sequence of actions is as follow:

  1. Enabled 2FA on the portal
  2. Backed it up from the portal, i.e. BAK-01
  3. Dumped everything but moved the backup tar ball BAK-01 to another location.
  4. Reinstall OnlyOffice with the same version of docker images
  5. Setup the newly installed OnlyOffice with the same owner account and password as previous
  6. Get into the portal backup page, and do a backup in temp location, i.e. BAK-02
  7. Overwrite the BAK-02 with BAK-01
  8. Get into the portal restore page, and restore the BAK-02, which is actually BAK-01
  9. After the restore, I cannot use the owner name and password to login the portal, neither other admins.
  10. Click on the “Forget Password”, I can get the email, and follow the reset password link, it will redirect me to the portal, asking for the Authenticator Code
  11. Input the code shown in my Authenticator App of my mobile, invalid.

Understood.

Your mistake was in the core.machinekey when you reinstalled WorkSpace.
You didn’t specify (core.machinekey from the previous portal) in the file:
(docker)
/app/onlyoffice/CommunityServer/data/.private/machinekey

  • Could you please clarify if you have the ability to find the core.machinekey of the portal to which “BAK-01” belonged?

User maxbon described how he dealt with his situation.