Odoo 16 connector nor work

Odoo connector not work for me
I installed onlyoffice documentserver latest release 7.4 on ubuntu 20.04. ( with NGINX and HTTPS Mode with letsencrypt SSL certificate) It works correctly with Owncloud, but tested with odoo16 community it keeps giving an error: “download failed”. Also with odoo16 enterprise (on premise) after service restart I get error 500 when try to open a Odoo file:

Traceback (most recent call last):
File “/opt/odooetp/odoo-server/odoo/http.py”, line 1579, in _serve_db
return service_model.retrying(self._serve_ir_http, self.env)
File “/opt/odooetp/odoo-server/odoo/service/model.py”, line 134, in retrying
result = func()
File “/opt/odooetp/odoo-server/odoo/http.py”, line 1608, in _serve_ir_http
response = self.dispatcher.dispatch(rule.endpoint, args)
File “/opt/odooetp/odoo-server/odoo/http.py”, line 1721, in dispatch
return self.request.registry[‘ir.http’]._dispatch(endpoint)
File “/opt/odooetp/odoo-server/addons/website/models/ir_http.py”, line 235, in _dispatch
response = super()._dispatch(endpoint)
File “/opt/odooetp/odoo-server/odoo/addons/base/models/ir_http.py”, line 144, in _dispatch
result = endpoint(**request.params)
File “/opt/odooetp/odoo-server/odoo/http.py”, line 698, in route_wrapper
result = endpoint(self, *args, **params_ok)
File “/opt/odooetp/custom-addons/onlyoffice_odoo/controllers/controllers.py”, line 87, in render_editor
return request.render(“onlyoffice_odoo.onlyoffice_editor”, self.prepare_editor_values(attachment, access_token))
File “/opt/odooetp/custom-addons/onlyoffice_odoo/controllers/controllers.py”, line 150, in prepare_editor_values
path_part = str(data[“id”]) + “?oo_security_token=” + security_token + ("&access_token=" + access_token if access_token else “”)
TypeError: can only concatenate str (not “bytes”) to str

Hello @vtomasi
Please provide us with additional details. If it’s possible please reproduce the situation (step-by-step usage scenario) and record a video file.
Additionally, please provide us with whole document server logs folder. It’s located here:
docker: /app/onlyoffice/DocumentServer/logs/documentserver/
deb\rpm: /var/log/onlyoffice/documentserver/
Windows: Program Files\ONLYOFFICE\DocumentServer\log

cannot load zip files with issues details.


You can upload files to any external storage and provide us with download link.

download from filetransfer.io


Hello @vtomasi

Please see my message from the thread where similar issue is discussed for more information:

Hello, Constantine,

I introduced the commit suggested in controllers/controller.py. Restarted Odoo. The error remains the same.
Yesterday I downloaded the onlyoffice documents module from apps.odoo.com and installed it in odoo 16 enterprise. First removed the old onlyoffice.odoo module. Activated both new modules: onlyoffice_odoo and onlyoffice_odoo_documents. Restarted odoo 16. Still the same error.


Can you make screenshot of the apps that you have installed to your Odoo instance?

By the way, with the latest app you don’t have to make any changes manually, the fix was already implemented. Is it possible to reinstall those again with the guide?

Hello, Constantine,
I uninstalled the old Onlyoffice connector, then restarted the odoo server. Then I downloaded the latest version of the connector from the apps.odoo.com site which I saw already contains the code change you are referring to. Restarted the server again (rel. 16 enterprise). The error remains the same. I also tried installing onlyoffice connector in a clean database but I get the same error.

Since you are using Odoo Enterprise, please let me know if you are using Odoo Documents module in your portal. In general, is it possible to record a video of your actions while reproducing the issue for better understanding?