Internal server error after install

So, this is what it outputs

JWT enabled - true
JWT secret - HBFZSQSepSbRKPy0wpijSBQwGOQ2ic9a
JWT header - Authorization

This JWT is exactly as it is specified in yaml-file for docker container:

version: '3'
      context: .
    container_name: onlyoffice-documentserver
      - onlyoffice-rabbitmq
      - DB_TYPE=mariadb
      - DB_HOST=
      - DB_PORT=3306
      - DB_NAME=onlyoffice
      - DB_USER=onlyoffice
      - AMQP_URI=amqp://guest:guest@onlyoffice-rabbitmq
      # Uncomment strings below to enable the JSON Web Token validation.
      - JWT_ENABLED=true
      - JWT_HEADER=Authorization
      - JWT_IN_BODY=true
      - '8081:80'
      - '8082:8080'
      - '4433:443'
    stdin_open: true
    restart: always
    stop_grace_period: 60s
       - /var/www/onlyoffice/Data
       - /var/log/onlyoffice
       - /var/lib/onlyoffice/documentserver/App_Data/cache/files
       - /var/www/onlyoffice/documentserver-example/public/files
       - /usr/share/fonts
    container_name: onlyoffice-rabbitmq
    image: rabbitmq
    restart: always
      - '5672'

Hi @vomus
I clarified this information with “@_mnt:upside_down_face:

If I understand correctly, your issue seems to be with specifying the address of the document server on your end, because the document server is in working correctly.

The main thing needed to connect the document server to the document repository is to remember that…
Document Editing Service adderss ->‘http://<document_server>/’

*where the document_server is the name or IP of the server with the ONLYOFFICE Docs installed.

The address must be accessible for the user browser and from the Redmine server.
The Redmine server address must also be accessible from ONLYOFFICE Docs for correct work.

No, my issue is not specifing the address per se… The document server is running normally and it is accessable directly with my browser through


( I mapped 80 to 8081 in docker because 80 is where Redmine sits). Redmine is also running just fine.

They both are functioning just fine. But!!! When I specify documentserver’s address


in the Redmine OnlyOffice plugin’s settings it tells me that there is an internal error.


Try specifying the external address (IP) of the document server in the connector (not the container address).

If possible, please provide a screenshot indicating the IP address of the document server in the connector configuration.

I did this already, and I wrote about it above (on the 25th of April). The external address is

Hi @vomus :wave:

  1. Does your example page work when accessed via the address: ip:8081? (As far as I remember, your DS is located on port 8081)

  2. Please send a screenshot of the settings page for the onlyoffice_connector plugin.

  3. Provide the latest Redmine logs and the logs from /var/log/onlyoffice/documentserver/converter/out.log.

I get a almost same question

my ONLYOFFICE is 8.0, the IP address of the machine with ONLYOFFICE Docs installed in, the project running, it seems OK.

but when I connect with Confluence ,( my confluence is 8.5.2 ,webside is : ,
the Plugin is 5.0), I get a Error.

I have already change local.json and I Fill in the Plugin Page as require:
By the way ,my linux server is offline.

Hello @wangpf :wave:

Could you please create a separate topic for discussing this issue? Additionally, I need some more information:

  1. I want to inform you that the current version of the document server is 8.1.:slight_smile:
  2. Type of installation of Document Server (exe, docker, deb/rpm).
  3. How is your network set up?
  4. Please provide a link to an archive containing the following files:
  • local.json
  • default.json
  • logs from the /var/log/onlyoffice/documentserver/ directory
  1. Is the trial period activation for ONLYOFFICE working?

Thank you.